View Issue Details

IDProjectCategoryView StatusLast Update
0007237Multi Theft Auto : San AndreasClientpublic2012-08-20 17:08
ReporterNeXTremeAssigned Toccw 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.1Fixed in Version1.3.1 
Summary0007237: [REQUEST] warpPedIntoVehicle client-side
Description

I've seen a couple of these requests here from 2009, but nothing seems to have been done about them.

This is something that should definitely be implemented, warping client-side peds into client-side vehicles. It's so annoying to always have to create everything server-side, use dimensions to hide the stuff from other players, etc., and all you want to do is make a simple cutscene.

TagsNo tags attached.

Activities

_Spanish4Life

2012-08-08 12:47

viewer   ~~0017241

Not very usuable.

Remi-X

2012-08-08 12:57

reporter   ~~0017244

lol he just told what its useful for, and you call it "not very usable"? Imo, it's not a that bad idea. You won't need to bother every player with new elements to make a cutscene for one player with such a function.

I only see major issues according to sync. If you warp a clientside ped in a serverside vehicle with this, it would heavily bug. So this either has to be prevented, or the function is too much of a hassle.

W

2012-08-08 13:00

viewer   ~~0017246

Last edited: 2012-08-08 13:21

Also it would bug when warping players to vehicles created clientside, causing at least desynchronisation.

NeXTreme

2012-08-10 14:27

viewer   ~~0017270

Oh no no, this is only for CLIENT-SIDE peds AND vehicles. You could not be able to warp a client-side ped to a server-side vehicle and vice-versa. Also you couldn't be able to warp players into client-side vehicles, only PEDS (created via createPed)

W

2012-08-10 14:29

viewer   ~~0017271

Last edited: 2012-08-10 14:29

How would that look to other player, when ped created on other client is warped to vehicle created on other client? It will bug heavily.

NeXTreme

2012-08-10 14:42

viewer   ~~0017272

I don't think that would ever be possible, since an element created on one client does not exist on another? Or am I wrong here

arranTuna

2012-08-19 14:52

manager   ~~0017317

http://code.google.com/p/mtasa-blue/source/detail?r=4480

Issue History

Date Modified Username Field Change