View Issue Details

IDProjectCategoryView StatusLast Update
0007184Multi Theft Auto : San AndreasServerpublic2012-07-16 14:36
ReporterH5N1[PL]Assigned Toccw 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOS7OS Version7601 SP1
Product Version 
Target Version1.3.1Fixed in Version1.3.1 
Summary0007184: MYSQL - tinyint returning as a string
Description

Hello, I discovered annoying bug with mysql functions (built in MTA). When you send query which want to load data from types like 'tinyint', 'int', 'smallint', 'mediumint' and 'bigint', tinyint will return as a string, but rest of those types as an integer. It's annoying because I must make everywhere tonumber to make script works. Please fix it quickly.

Steps To Reproduce

CREATE TABLE test (data1 int, data2 tinyint)
SELECT data1,data2 FROM test

TagsNo tags attached.

Relationships

related to 0007191 resolvedccw MYSQL - float and decimal returning as a string 

Activities

Issue History

Date Modified Username Field Change