View Issue Details

IDProjectCategoryView StatusLast Update
0007142Multi Theft Auto : San AndreasScriptingpublic2014-04-09 18:36
ReporterrobholAssigned Toryden 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.5Fixed in Version1.3.5 
Summary0007142: Provide simple encryption functions?
Description

Currently, there is no decent way to encrypt and decrypt stuff - we don't have access to third party libraries (which is probably a good idea) - and implementing an algorithm in Lua is both extremely slow and somewhat infeasible due to the lack of bitwise operations etc.

Since we've had access to MD5 and SHA1 for a long time, how about some AES or something similar? Finding a decent implementation is almost impossible in Lua, but should be a walk in the park for C++.

TagsNo tags attached.

Activities

PhatLooser

2012-06-29 17:56

reporter   ~~0016919

Last edited: 2012-06-29 17:58

Like that?
http://forum.multitheftauto.com/viewtopic.php?f=91&t=32021&sid=014bf5da7021e5b6746ad6c068e456f6

Yes, consider it slow.
Implemented in C++ it would be 100 times faster.

robhol

2012-06-29 18:00

reporter   ~~0016920

Not bad, but a C++ implementation of AES or something would be even not-badder. :)
Of course, the weakest link in a setup like this would most likely not be in the choice of algorithm.

Would be faster though, and probably not a lot of work.

PhatLooser

2012-06-29 18:01

reporter   ~~0016921

I'd approve of AES since its open-source.
Once upon a time I implemented it in Java, so C++ shouldn't be an issue.

arranTuna

2014-04-09 18:36

manager   ~~0020636

http://code.google.com/p/mtasa-blue/source/detail?r=4882
http://code.google.com/p/mtasa-blue/source/detail?r=4883

Which got added to 1.3.5:
http://code.google.com/p/mtasa-blue/source/detail?r=6056

Issue History

Date Modified Username Field Change