View Issue Details

IDProjectCategoryView StatusLast Update
0007125Multi Theft Auto : San AndreasServerpublic2012-08-20 17:08
ReporternichAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.1Fixed in Version1.3.1 
Summary0007125: Teamsay + long name + long message = too long message
Description

Maximum chatbox input = 96 char
Maximum name = 22 char
Additional characters = 7 (colorcode) + 9 [ (TEAM) : ]

Maximum of 134 (limit: 128) characters which means that players with longer names cannot utilize the full chatbox input, otherwise their messages don't get output to the chatbox.

I would combine this report with the previous suggestion I made, because not counting colorcodes towards characterlimit would fix this issue as well.

TagsNo tags attached.

Activities

SHC//Sniper

2012-06-19 19:21

reporter   ~~0016849

That's right, it should be fixed.

qaisjp

2012-06-30 10:26

administrator   ~~0016928

Not counting hex colors should be counted, also a name with only hex color should fail. Setting a too long name also gives the wrong error.

LeetWoovie

2012-07-03 11:05

viewer   ~~0016952

Write your own chatbox.

ccw

2012-08-20 03:28

administrator   ~~0017332

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=4535

Issue History

Date Modified Username Field Change