View Issue Details

IDProjectCategoryView StatusLast Update
0007081New Feature Requests[All Projects] Generalpublic2018-09-30 14:28
ReporterarranTunaAssigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionopen 
Summary0007081: Request: Function to detect or automatically remove network troubled players
Description

There are many players who give themselves network trouble with things like locking their computer thus making them invincible for as long as they want.

So either people should get automatically kicked for lengthy network trouble or a function so we can kick them manually as one network troubled player can block events played by 100+ from ending.

TagsNo tags attached.

Users sponsoring this issue
Sponsors List Total Sponsorship = EUR 10

2012-05-25 22:33: arranTuna (EUR 10)
Users sponsoring this issue (Total Sponsorship = EUR 10)

Activities

qaisjp

2012-07-05 17:01

administrator   ~~0016965

Event: onPlayerNetworkTroubled (source = player)
Function: getPlayerNetworkTroubleTime(player)
returns 0 if not troubled, returns ms of troubled.

So to kick troubled idiot for 1 minute:
function kickTroubled(p)
if getPlayerNetworkTroubleTime(player) > 551000 then
kickPlayer(p)
end
end
addEventHandler("onPlayerNetworkTroubled", root, function()
local p = source
setTimer(kickTroubled, 60
1000, 1, p)
end
)

ALTERNATIVELY
you could do a ping kick. (long network trouble = big ping)

PhatLooser

2012-07-05 19:19

reporter   ~~0016974

Last edited: 2012-07-05 19:34

I can't find "onPlayerNetworkTroubled" in the wiki, please link it.
Also, most of those "network troubled" players actually can keep a low ping while abusing the Windows Logout Function.

Arran is right.
The current way network trouble is handled is very, very, very, very, very annoying for deathmatch games.
Example: "Spiriting away". A player hides, "spirits away" (network trouble), all the other players leave the "checkpoint", he "spirits back" and BAM! takes over the checkpoint alone.
Another Example: Last man standing. A player hides, "spirits away" and can't get found on the whole map since he's gone. He can't even be found, since network trouble always warps a player underground.

Worst thing is, this cannot be detected server side!
Not without abusing bandwidth.

Ghost_X

2012-07-07 16:14

viewer   ~~0016987

Phat, I think he (qaisjp) was just suggesting the name of event and functions.

Issue History

Date Modified Username Field Change