View Issue Details

IDProjectCategoryView StatusLast Update
0007074Multi Theft Auto : San AndreasClientpublic2012-05-20 20:54
ReporterKernellAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.1Fixed in Version1.3.1 
Summary0007074: onClientWorldSound not canceled
Description

onClientWorldSound not be canceled for the sounds of the 5 group (weapon sounds)

http://wiki.multitheftauto.com/wiki/OnClientWorldSound

Example on wiki does not work!

TagsNo tags attached.

Activities

arranTuna

2012-05-14 20:49

manager   ~~0016647

It only seems to cancel some sounds.

It only cancels the reloading sounds and makes the MP5 firing sound different.

Kernell

2012-05-15 10:14

reporter   ~~0016648

arranTuna,
and what? For you, is this normal?

arranTuna

2012-05-15 12:03

manager   ~~0016649

Normal? No, it's meant to cancel all sounds but it seems to work for everything but shooting sounds, satchel explosion and maybe other explosions.

ccw

2012-05-18 21:23

administrator   ~~0016671

Cancelling everything with onClientWorldSound mutes all GTA sfx for me.

I think this event may need reverting

Remi-X

2012-05-19 03:05

reporter   ~~0016672

It works for me too, and so does it for Wafamde if I may tell that for him. We just did some testings on my server (r4129) and the game was totally silent except for the air sound and some sounds from group 0 such as index 11, the "unable to shoot" sound which you get when trying to shoot with a sniper/rpg without aiming. Im totally happy with it, and offers a lot of possibilities.

ccw

2012-05-19 13:21

administrator   ~~0016675

It has to work for everyone though, otherwise it is broken

Remi-X

2012-05-19 13:41

reporter   ~~0016676

I don't see why it can't work for some people?

x86

2012-05-20 20:53

administrator   ~~0016685

Fixed in: http://code.google.com/p/mtasa-blue/source/detail?r=4133

Issue History

Date Modified Username Field Change