View Issue Details

IDProjectCategoryView StatusLast Update
0007031Multi Theft Auto : San AndreasServerpublic2015-07-16 17:38
ReporterKenixAssigned Toccw 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.5Fixed in Version1.5 
Summary0007031: SQLite supports only latin characters in path
Description

See

Steps To Reproduce

For example (path) D:/уфхцчшщъ/server/ ...

===========================================================
= Multi Theft Auto: San Andreas v1.3

= Server name : **
= Server IP address:
= Server port : *
=
= Log file : ..чшщъ/server/mods/deathmatch/logs/server.log
= Maximum players : ***
= HTTP port :

= Voice Chat : Quality [4]; Sample Rate: [16000kHz]

[2012-04-26 19:38:56] ERROR: [2012-04-26 19:38:56] ERROR: Invalid connection
[2012-04-26 19:38:56] ERROR: Errors were encountered loading 'internal.db' database
[2012-04-26 19:38:56] ERROR: Maybe now is the perfect time to panic.
[2012-04-26 19:38:56] ERROR: See - http://wiki.multitheftauto.com/wiki/fixdb
[2012-04-26 19:38:56] ERROR: ****

TagsNo tags attached.

Relationships

child of 0006375 closed New issues Unicode issues 

Activities

Kenix

2012-04-26 17:43

updater   ~~0016542

Last edited: 2015-02-17 20:25

View 2 revisions

Where уфхцчшщъ it's russian characters

W

2012-04-27 08:49

viewer   ~~0016548

Problem does not occur under Linux.

Kenix

2012-04-27 11:42

updater   ~~0016549

Last edited: 2013-01-08 12:41

I tested on Windows 7 32-bit

ccw

2015-02-17 04:20

administrator   ~~0023017

Last edited: 2015-02-17 20:25

View 3 revisions

Is this still a problem?

Bpb_Xommko

2015-02-17 09:35

viewer   ~~0023018

Seems it's been fixed. Can't reproduce on 1.4.1.

Strix

2015-02-17 10:15

viewer   ~~0023019

Last edited: 2015-02-17 14:35

View 4 revisions

I have a little different problem with non-latin characters in path on MTA 1.5, Windows 8.1
https://www.dropbox.com/s/qtyprhwkd3rkeoy/x.png

pasta50

2015-02-17 11:51

viewer   ~~0023020

No shit.
There we have Strix again.
Thanks for your wonderful contribution to Mantis, your bug reports
and comments are always very on-topic and contain alot of sense relating
to the issues.

Strix

2015-02-17 14:36

viewer   ~~0023021

On 1.4.1 this can't be reproduced

ccw

2015-02-17 22:13

administrator   ~~0023022

Last edited: 2015-02-17 22:13

View 2 revisions

Strix, what is the exact path which is failing for you in 1.5?

Strix

2015-02-17 22:21

viewer   ~~0023023

"C:/aa/ё/MTA Server.exe"

ccw

2015-02-18 01:49

administrator   ~~0023024

1.5 issue fixed in https://code.google.com/p/mtasa-blue/source/detail?r=7086

Issue History

Date Modified Username Field Change