View Issue Details

IDProjectCategoryView StatusLast Update
0007020Multi Theft Auto : San AndreasClientpublic2012-10-09 22:01
ReporterRemi-XAssigned Toccw 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.2Fixed in Version1.3.2 
Summary0007020: onClientPlayerWeaponFire returns incorrect hit positions
Description

Title says all. The hit where the bullet is actually located, is not the same as what the event gives us.

http://dl.dropbox.com/u/51741996/MTA/bulletz.png

Also, it seems to be affected per client which makes the issue a bit more complex.
[PS]MAR had this when I was shooting: http://i.imgur.com/KJLKc.jpg
Not a 100% correct position as you can see, but I had this:
http://dl.dropbox.com/u/51741996/MTA/bulletz3.png
Which is far worse.

We both shot at the corner of the building:
http://dl.dropbox.com/u/51741996/MTA/bulletz4.png

The problem is quite obvious when shooting at players too:
http://dl.dropbox.com/u/51741996/MTA/bulletz5.png

Additional Information

I've showed a lot of minugun here, but the bug happens to all weapons EXCEPT the sniper. Only the sniper seems to be fully accurate.

This is the script I used to test:
http://pastebin.com/p4KyUzjG

Imo, it's not a minor issue. Its blocking some scripts I want to make because of this inaccuracy.

TagsNo tags attached.

Relationships

related to 0006788 closed New Feature Requests [Request] Option align gun muzzle and cross-hair 
has duplicate 0007186 closed New issues onClientPlayerWeaponFire does not return correct x,y,z hit coordinates if the player is not aiming. 

Activities

Remi-X

2012-05-29 18:40

reporter   ~~0016718

Last edited: 2012-06-14 20:13

Forgot to upload a vid clearly demonstrating the problem:
http://www.youtube.com/watch?v=-dFFba-XMsw

Any info about it? Would love to make some scripts that rely on this accuracy :(

EDIT: Entire resource:
https://dl.dropbox.com/u/51741996/MTA/bulletsync.rar

CWanted

2012-10-07 19:56

updater   ~~0017698

http://code.google.com/p/mtasa-blue/source/detail?r=4311
http://code.google.com/p/mtasa-blue/source/detail?r=4426

Issue History

Date Modified Username Field Change