View Issue Details

IDProjectCategoryView StatusLast Update
0006988Multi Theft Auto : San AndreasClientpublic2014-05-10 11:22
ReporterasturelAssigned Toccw 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.1Fixed in Version1.3.1 
Summary0006988: guiComboBoxGetItemText crash when the itemid is greater then the combobox row count
Description

since there is no function for get the row count it is easy to overindex :/

p.s.: 'guiComboBoxGetRowCount' would be nice

Steps To Reproduce

crun local vehiclesComboBox = guiCreateComboBox ( 400, 100, 200, 5 * getElementsByType "vehicle" ), "", false );
guiComboBoxGetItemText(vehiclesComboBox,2);

TagsNo tags attached.

Users sponsoring this issue
Sponsors List Total Sponsorship = EUR 1

2012-08-19 04:56: asturel (EUR 1)
Users sponsoring this issue (Total Sponsorship = EUR 1)

Issue History

Date Modified Username Field Change