View Issue Details

IDProjectCategoryView StatusLast Update
0006938Multi Theft Auto : San AndreasServerpublic2014-01-30 12:53
ReporterJacobSAssigned ToJusonex 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.5Fixed in Version1.3.5 
Summary0006938: Furniture doesn't remove from house robbery interiors
Description

Okay, plain and simple, I've tried removing furniture from all the interiors and there are just some that the furniture will not disappear from. I don't know if it's LOD objects or SCM or what..

Steps To Reproduce

Remove furniture in an interior with removeWorldModel
Check other interiors with the furniture - some will have it, some won't.

TagsNo tags attached.

Relationships

related to 0007657 closed Can't delete dyn. objects like rocks or desert trees 

Activities

JacobS

2012-03-15 02:27

viewer   ~~0016292

"In the safe-house interiors, it works..But in the house-robbery thingy interiors it doesn't work at all, it doesn't remove ONE SINGLE piece of furniture. It only does it in the safe-houses."

Cazomino05

2012-03-16 11:08

reporter   ~~0016297

it can't be SCM we disable it, chances are radius is too high or unfortunately the models are so offset from their COM that you are catching them all in an effort to remove one can you tell me which models in which interior you tried to remove?

JacobS

2012-03-21 21:50

viewer   ~~0016345

The problem isn't that it's removing all the furniture, the problem is that it doesn't remove any from the burglary house interiors even though it removes it all from the safe house interiors.

The ones in the burglary interiors are the exact same objects as the ones in the safe house interiors but they just don't get removed.

I can PM you the script on the forums if you'd like to test it for yourself, but the furniture list is very long, at least 200 objects, so I couldn't account for them all specifically here.

JacobS

2012-03-21 21:52

viewer   ~~0016346

In short, I'm trying to remove all furniture from the interiors, but it only ever gets removed from the safe house interiors, not the burglary house interiors.

JacobS

2012-03-25 16:46

viewer   ~~0016369

It does also remove them from shop interiors. Just not the burglary houses.

JacobS

2012-05-20 03:55

viewer   ~~0016682

Last edited: 2012-05-20 03:59

I've figured out that it's caused by the burglary houses loading, there are different variants of the burglary houses which are loaded during the ingame missions. MTA loads a certain set of furniture (the same every time) every time you enter.

So possibly a function to handle this? toggleBurglaryHouseFurniture() or something along those lines?

http://www.youtube.com/watch?feature=fvwp&NR=1&v=M2uW0zlj3WI - EXAMPLE

Muffins

2012-06-21 02:14

viewer   ~~0016867

Bump, this needs to be fixed already.

JoeBullet

2012-06-21 02:19

updater   ~~0016868

@Whoever is going to fix this@: Have a look at CInteriorFurnitureSA in my branch jb-contrib and contact me...

qaisjp

2012-06-28 18:19

administrator   ~~0016902

It looks like you have a wrong branch base, its based on features, not on user contributions

Muffins

2012-07-01 05:06

viewer   ~~0016937

Date submitted: 2012-03-11 21:05, seriously, four months passed..

Muffins

2012-08-02 14:30

viewer   ~~0017183

5Months now..

arranTuna

2012-08-02 16:37

manager   ~~0017184

Then why don't you fix it, instead of complaining that nobody else wants to fix your stupid bug?

JacobS

2012-08-02 19:39

viewer   ~~0017185

Because none of us know C.

If it's so stupid that you expect a bunch of guys who don't know anything about this stuff to fix it, then it must be easy right? So why can't it be resolved?

I'm seeing bugs that are getting fixed days after they're submitted and you can't fix this?

What is it that JoeBullet submitted, is that a solution? If it's that easy you should check it out instead of getting rude with us.

MrMuLTiVaN

2012-08-04 15:15

viewer   ~~0017199

My problem is, If I enter a house interior, and other players to, I do not see the furinture, but other players see it.

JoeBullet

2012-08-05 12:59

updater   ~~0017203

Could you please provide test code showing the bug.

Muffins

2012-08-05 15:20

viewer   ~~0017205

@JpeBullet, I am not a LUA scripter, but what he basically did was remove every single furniture model from the interiors using removeworldmodel, but it doesn't disappear from the burglary houses( http://wiki.multitheftauto.com/wiki/Interior_IDs )
e.g Burglary House 18 327.808 1479.74 1084.438, interior id 15

JacobS is on vacation right now, so he can not provide you with an example, but I'm sure that you, or maybe anyone else watching this ticket can make a script to remove model ID 1768 from all of the interiors, that's pretty much what JacobS did.

For this experiment, we will use burglary house 18 and safe house15. I posted the coords of Burglary House 18 up there, and safe house 15 is 2308.79 -1212.88 1048.03 world 6.

Now, after removing that couch from the whole server, go into safe house 15. To the left of the entrance( pic of location http://puu.sh/OOJO), there should be a couch. That one will get removed.

Go to the burglary house. To the left of the entrance, there's the kitchen. The kitchen leads to the living room. The living room will still have the couch.(pic of location http://puu.sh/OOLY).

I hope this helped, cheers.

Muffins

2012-08-05 15:22

viewer   ~~0017206

Forgot to mention, he stores all the IDs in an array and then goes through it to get all the models deleted, without typing removeworldmodel tens of times.

JoeBullet

2012-08-05 16:49

updater   ~~0017212

It seems that you either provided me wrong coordinates or wrong model id because I was unable to remove that couch. If someone is Lua scripter and can provide me test code that will really help solve this issue faster.

dragonofdark

2012-08-05 18:25

viewer   ~~0017213

Don't know if this is related, but when I try to remove id 3675, it doesn't seem to work.

Try to use this : removeWorldModel(3675,50,2675,-2118,20)

and go there : http://img15.hostingpics.net/pics/906456mtascreen20120805182352.png

You will see that the white tubes are still there.

Muffins

2012-08-05 19:06

viewer   ~~0017214

@JoeBullet, exactly, you can't remove that couch. I gave you good coordinates and good model, it simply won't remove. That's the issue that we're trying to get fixed.

Maybe you could get on IRC and we could talk easier there?

@Dragonofdark, it's not the same issue. The tubes are a separate model.

JoeBullet

2012-08-05 19:07

updater   ~~0017215

I am on IRC, nick: JoeBullet(or JoeBullet_).
You said one couch should get removed and another should not.

W

2012-08-05 19:59

viewer   ~~0017216

Last edited: 2012-08-05 20:01

I can't reproduce this issue.
My test resource: http://lss-rp.pl/_/6938.zip

It removes all objects and positions player in said place (327, 1479, 1084.438, interior=15). Everything is gone.

Maybe you're just removing wrong object id?

Muffins

2012-08-05 20:22

viewer   ~~0017217

You resource deletes EVERYTHING in the whole game, every single model everywhere, meaning that you delete the actual HOUSE object, deleting the house, reason why everything is gone.

We want only the FURNITURE gone.

Muffins

2012-08-09 02:56

viewer   ~~0017260

Any updates on this?

Mr.Hankey

2012-08-09 11:56

reporter   ~~0017261

Last edited: 2012-08-09 12:16

If removing the house object also removes all furniture then maybe that furniture is a part of the house object. That means you simply cannot remove just the furniture. It might be a gta limitation if you want to put it that way.

Muffins

2012-08-09 16:00

viewer   ~~0017263

It's not a GTA limitation, it's an MTA one. If you remove the house object, the furniture won't disappear. BUT, if you try to remove the furniture itself, it won't disappear either. It only happens in the burglary interiors, did you even download his resource to see what happens?

His resource deletes EVERY SINGLE MODEL IN THE GAME, the streets, the blocks, everything. You CAN remove just the furniture, just that there's an MTA bug. If it's in the house object, then how come it can be removed with med? Trust me, we know that it's a bug after 4 months of it.

dragonofdark

2012-08-15 20:43

viewer   ~~0017298

@Muffins : What do you mean by separate model ?

Wafamde

2012-08-16 15:40

viewer   ~~0017301

Muffins - Instead of crying for 5-6 months, wouldnt it have been easier for you to create a custom model of the house? Seems to me that you have had plenty of time to do so. Its a shame that the issue doesnt get solved, but you have had a lot of time to work around it yourself. MTA bug or not.. There are ways around this.

JacobS

2012-08-17 22:06

viewer   ~~0017305

First of all ain't nobody "crying" so stow that, how about you consider the words you're using?

The furniture is NOT attached to the house model. Look at map editor. You can place the blank models of the house. But in order to make that compatible with our script you would have to generate one in every dimension. That's not going to happen.

If you don't have a productive answer, just don't speak.

We told you folks the cause of it, now somebody fix it.

It's caused because when you enter the burglary house interiors it generates the first furniture variant in the set.

Block it from generating the furniture.

It's not hard to understand.

No reason for anyone to continue to be rude here.

DONE.

JoeBullet

2012-08-17 22:18

updater   ~~0017306

Still waiting for testcase...

JacobS

2012-09-28 21:59

viewer   ~~0017643

http://pastebin.com/8S3WCqf1

This is an extremely toned down version of the script I made.
It's meant to demonstrate in this interior: http://puu.sh/19tRG
Coordinates: 220.68, 1287.97, 1082.14
Interior #1

The script should remove the pink couch (1763) from the living room, and the Nintendo (1719) from on top of the table. It does neither, though, because those objects are loaded as burglary house furniture.

However, the full version of the script has no problem removing the furniture from safe houses and shop interiors. See: http://puu.sh/19tTE

Jusonex

2014-01-30 10:46

administrator   ~~0020105

Such combination of furniture gets generated randomly by GTA so that I decided to introduce a function (setInteriorFurnitureEnabled) to disable the furnishing process entirely (per rooom).

https://code.google.com/p/mtasa-blue/source/detail?r=6097

Issue History

Date Modified Username Field Change