View Issue Details

IDProjectCategoryView StatusLast Update
0006876Multi Theft Auto : San AndreasServerpublic2012-02-14 23:12
ReporterdrifterCZAssigned Toccw 
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.1Fixed in Version1.3.1 
Summary0006876: Map files are downloading very slow
Description

Downloading map files is very slow.
It runs about 2kb/s for me.
Other files from server downloads about 200kb/s, so its NOT caused by my connection.

Steps To Reproduce

Sometime map download fast but I don't know how to reproduce it

Additional Information

MTA:SA 1.3
When map is downloading, no informations are recieved from server, and it keeps like that for about next 10 or more seconds after map download finishes. This doesnt happen when downloading other files.

up to 9 of 10 map downloads causes this problem for me.

TagsNo tags attached.

Relationships

related to 0006877 closed New issues Chat messages don't update while a map download is in progress 

Activities

drifterCZ

2012-02-09 23:32

viewer   ~~0016009

Last edited: 2012-02-09 23:33

Sorry, with "no informations are recieved" I mean its in "lag"

diegofkda

2012-02-09 23:35

viewer   ~~0016010

Confirmed.

drifterCZ

2012-02-09 23:57

viewer   ~~0016011

I have found something interesting...
When server uptime is more than +- half an hour, download is fast.
And when I turn server off and on again, its slow again.

ccw

2012-02-10 00:13

administrator   ~~0016012

Last edited: 2012-02-10 00:13

Did this particular problem start in server r3834 ?

Feche

2012-02-10 02:35

viewer   ~~0016013

With r3834 it's very random.. sometimes maps download smooth and fast, sometimes it freezes at start and then it continues donwloading smooth and fast, and sometimes it just freezes and the download is slow.

MX_Master

2012-02-10 05:14

viewer   ~~0016014

.map files ~= client files, these files uses only server-side

server parses .map files, creates elements and so syncs this data with all clients.

"Sync data channel" always busy, that is why large sync packet downloads with random speed. While this large packet downloading, other sync data like chat messages is waiting. That is why chat is freezes while you downloading map data sync packet.

"Download data channel" is not busy in any time, that is why all client files downloads fast.

diegofkda

2012-02-10 05:35

viewer   ~~0016016

Server-side files download so slow, before, it was fine. Also, I experienced slower download server and client-side since 1.3 (since 1.1 to be honest, but it wasn't that important).

drifterCZ

2012-02-10 10:29

viewer   ~~0016018

ccw: no, it like that since we updated to 1.3
but since r3834 it seems like its no more giving timedouts
Feche: exactly
MX_Master: thanx for explaining

ccw

2012-02-10 11:20

administrator   ~~0016020

diegofkda: Problems with resource downloads are a separate issue. It is vital not to confuse the two.

ccw

2012-02-10 11:24

administrator   ~~0016021

To be honest, map downloads always were flaky. The map download in 1.3 used exactly the same code as 1.0.5 (before r3834). i.e. Less than perfect net connection -> problems

Someone suggested using the web server to transfer this data, which could be worth looking at.

drifterCZ

2012-02-10 13:34

viewer   ~~0016024

Last edited: 2012-02-11 01:50

But external web server could not be used to transfer maps

We do use external server for http client files

drifterCZ

2012-02-11 01:48

viewer   ~~0016032

Last edited: 2012-02-11 09:46

When map download is fast, there is no packetloss... but when its slow there is 0.5% packetloss or higher

So it seems like server has problem with resending lost packets, maybe?

ccw

2012-02-11 18:07

administrator   ~~0016034

Try server r3845

drifterCZ

2012-02-11 18:30

viewer   ~~0016037

Last edited: 2012-02-11 18:32

already tried, maybe faster than older 1.3 but still much worse then 1.2

ccw

2012-02-11 18:45

administrator   ~~0016040

I need to connect to your server to see what is going on. Please come to #mta

Feche

2012-02-11 19:28

viewer   ~~0016041

Last edited: 2012-02-11 19:28

I still get some little random freezes at map download, and I have some packetloss too.

ccw

2012-02-12 01:58

administrator   ~~0016048

Please try server r3846

Feche

2012-02-12 15:58

viewer   ~~0016051

http://i.imgur.com/nYYBe.png

Downloading at max speed.

drifterCZ

2012-02-12 20:03

viewer   ~~0016052

ccw: Absolutelly no change

ccw

2012-02-14 04:28

administrator   ~~0016062

Last edited: 2012-02-14 04:30

Please try server r3851

Add this to mtaserver.conf:
<net_type=4>

drifterCZ

2012-02-14 16:21

viewer   ~~0016066

Ok, I added <net_type>4</net_type>
and it downloads fast for all players (I tested it only a bit now). Seems even better than on 1.2
Thanks, nice job!

TwiX73

2012-02-14 18:54

viewer   ~~0016067

yeah... http://www.youtube.com/watch?v=BYYAQbTJbe0

SHC//Sniper

2012-02-14 21:12

reporter   ~~0016069

Confirmed, net_type 4 increases the download speed and there aren't any 2KB/s downloads anymore.

ccw

2012-02-14 21:13

administrator   ~~0016070

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=3852

Issue History

Date Modified Username Field Change