View Issue Details

IDProjectCategoryView StatusLast Update
0006871Multi Theft Auto : San AndreasServerpublic2012-03-21 22:59
ReporterPhatLooserAssigned Tokevuwk 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSDebian LennyOS Version64 bit
Product Version 
Target Version1.3.1Fixed in Version1.3.1 
Summary0006871: <map src="" dimension="0"></map> in meta crashes server
Description

<map src="" dimension="0"></map> crashes the server when in the meta.
Same goes for:
<map src="./" dimension="0"></map>
etc.

Steps To Reproduce

The meta file should look like this:

<meta>
<info name="[XR]Vertigo&#x0D;" author="unknown" date_made="[3/1/2011]" description="No Extra Information&#x0D;" gamemodes="race" type="map" version="1.0"></info>
<map src="race.map" dimension="0"></map>
<settings></settings>
<map src="" dimension="0"></map>
</meta>

TagsNo tags attached.

Activities

x86

2012-02-08 22:38

administrator   ~~0015987

Define "he created an illegal ".map" file.".

PhatLooser

2012-02-09 13:31

reporter   ~~0015993

Last edited: 2012-02-09 13:41

I found the reason for dat crash:
<map src="" dimension="0" />
This line seems the cause and solution to all of live's problems.

Happens on Debian 32 bit, Debian 64 bit and Ubuntu 32 bit.

kevuwk

2012-02-10 10:33

administrator   ~~0016019

unable to reproduce on a windows run server, I just get an error message telling me the map can't be found and subsequently can't start the resource

PhatLooser

2012-02-16 14:20

reporter   ~~0016080

I tried it on debian and ubuntu, and it seemed to work.
The server just got stuck in an endless loop.

kevuwk

2012-03-02 10:18

administrator   ~~0016201

Last edited: 2012-03-03 15:10

PhatLooser, i've just committed a change which will output to the log file some information that should help us identify where the problem is coming from. If you get the latest 1.4 unstable build and start the server with just the resource that is invalid, you should see some entries in server.log that look like "Meta.xml - Map: x". If you could let me know what number it ends at when it crashes, it should give me a better idea of where I should be looking

kevuwk

2012-03-08 00:05

administrator   ~~0016260

this should now be fine, have added a check to make sure that file names can't end with a /

PhatLooser

2012-03-21 22:59

reporter   ~~0016347

Sorry, but I didn't have much time recently. I'll try it out later (and, of course, try it out with the latest 1.3 build)

Issue History

Date Modified Username Field Change