View Issue Details

IDProjectCategoryView StatusLast Update
0006868Multi Theft Auto : San AndreasClientpublic2014-05-21 20:43
Reporterel_motoblockAssigned Tosbx320 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.4 
Summary0006868: engineReplaceModel not works with some models
Description

? ??????????
321 gun_dildo1
322 gun_dildo2
323 gun_vibe
325 flowera
326 gun_cane

heard somewhere
372 tec9

only TXD replacing works normal on this models

Steps To Reproduce

function ImportModels()
local txd_dil1 = engineLoadTXD ( "object/gun_dildo1.txd" )
engineImportTXD ( txd_dil1, 321 )
local dff_dil1 = engineLoadDFF ( "object/gun_dildo1.dff", 0 ) -- or with ', 321 )'
engineReplaceModel ( dff_dil1, 321 )
end
setTimer ( AttachToDildo, 3000, 1)

Additional Information

Please take a look at this problem!!!

TagsNo tags attached.

Relationships

duplicate of 0008129 resolvedsbx320 Replacing a specific weaponmodel will crash your client 

Activities

Kernell

2012-02-08 12:57

reporter   ~~0015975

Why MTA not consider this issue? It is very important!

MX_Master

2012-02-08 15:40

viewer   ~~0015976

confirmed

ccw

2012-02-08 15:59

administrator   ~~0015977

Last edited: 2012-02-08 16:00

Did it work before?

MX_Master

2012-02-08 17:16

viewer   ~~0015978

no, always were crashes from that time where this ability was added

ccw

2012-02-08 18:08

administrator   ~~0015984

Does it work if you import the original model?

el_motoblock

2012-02-09 07:11

viewer   ~~0015988

Last edited: 2012-02-09 07:11

370 - Jet pack
371 - Parachute
372 - Tec-9
too

MX_Master

2012-02-09 09:05

viewer   ~~0015989

Does it work if you import the original model?

I tried to replace tec9 to original tec9 model. Result is crash (:

Loki97

2012-02-09 09:29

viewer   ~~0015990

It is very bas, i want to see corrected in 1.4 = (

sbx320

2014-05-21 20:43

administrator   ~~0020924

Fixed in https://code.google.com/p/mtasa-blue/source/detail?r=6439

See also http://bugs.mtasa.com/view.php?id=8129#c20920

Issue History

Date Modified Username Field Change