View Issue Details

IDProjectCategoryView StatusLast Update
0006835Multi Theft Auto : San AndreasServerpublic2012-02-03 09:58
ReporterarranTunaAssigned Toccw 
PrioritynormalSeveritycrashReproducibilityrandom
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.1Fixed in Version1.3.1 
Summary0006835: Server logic/lua/CLuaFunctionRef.cpp:72 assertion error
Description

The server was stalling for minutes, that little bar at the top saying FPS and such was gone and everyone had network trouble, during that time I restarted a script and when it finally went through there it gave an assertion error.

TagsNo tags attached.

Activities

ccw

2012-01-26 22:58

administrator   ~~0015840

Any dump? (Retry on assertions should produce a dump file)

Cazomino05

2012-01-26 22:59

reporter   ~~0015841

this is caused by triggering a database query on a stopping resource so it can't find the callback ergo assert

lil_Toady

2012-01-26 23:03

administrator   ~~0015842

Way to reproduce:

function callback () end
addEventHandler ( "onResourceStop", getResourceRootElement(), function ()
local db = dbConnect ( "sqlite", "test.db" )
dbQuery ( callback, db, "SELECT * FROM sqlite_master" )
end )

But also gotta be checked with callRemote i guess, it does it the similar way

Picard

2012-01-27 01:18

updater   ~~0015846

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=3756 )

Picard

2012-01-27 15:13

updater   ~~0015858

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=3757 )

Issue History

Date Modified Username Field Change