View Issue Details

IDProjectCategoryView StatusLast Update
0006831Multi Theft Auto : San AndreasServerpublic2012-12-29 11:23
ReporterAeroXbirdAssigned Toryden 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSDebian LinuxOS Version6.0 32bit
Product Version 
Target Version1.3.2Fixed in Version1.3.2 
Summary0006831: protected option for protecting client side files stops files from loading.
Description

For some reason when you add protected="true" in your resource's meta.xml file, the client file you put the tag in stops loading.
Removing cache folder does not fix the issue, I'm not using any external http server to load my scripts from either.
The debug does not show any errors whatsoever.

TagsNo tags attached.

Activities

AeroXbird

2012-01-26 13:28

viewer   ~~0015824

I just extensively tested this issue, and it seems to work just fine on windows, but not on linux.
On my server i have soft-linked the resource-cache/http-client-files to a folder on my webserver, this is to download from an HTTP server.
I tried softlinking the resource-cache/http-client-files-protected to the folder on my webserver, without succes the client files are still failing to be loaded.
Once i remove the protected="true" tags however, they load just fine, given that i have soft-linked the webserver to resource-cache/http-client-files.
It seems like something is going wrong with the loading from the resource-cache/http-client-files-protected folder..

ryden

2012-01-27 15:18

manager   ~~0015859

Last edited: 2012-01-27 15:19

You shouldn't be generating that folders by yourself. Use the resources folder instead.

AeroXbird

2012-01-27 15:22

viewer   ~~0015860

But as i want my players to download using an external http server, i have to copy the client-side files to the http server, if i copy the whole resource folder my serverside code will be amongst that..
correct me if i'm wrong.

ccw

2012-01-27 15:28

administrator   ~~0015861

Linking to resource-cache/http-client-files is correct

AeroXbird

2012-01-27 15:32

viewer   ~~0015862

I have just tried turning the function on without the external HTTP server, no success.

It still refuses to load the protected files, and it does not output any error whatsoever.

Audifire

2012-02-13 20:17

viewer   ~~0016059

I tested it on linux server, too.
The problem is like discripted, it won't work.

drifterCZ

2012-02-29 18:43

viewer   ~~0016184

please fix it its very important!! everyone can steal scripts if its not compiled

qaisjp

2012-03-18 14:43

administrator   ~~0016317

protected="true" doesn't compile anything

JR10

2012-03-20 04:17

viewer   ~~0016336

If I'm right, it stops the clientside scripts from being saved on the client's hard disk. It's important to fix it.

asturel

2012-03-23 19:48

reporter   ~~0016361

Last edited: 2012-03-23 19:49

qaisjp: if it doesnt compile the source what prevents the user from download it from the external webserver? and if the source is compiled u dont have to redownload every time the file (ofc when if its unmodified)

btw. since the 'http-client-files-protected' folder is not public, how can the users EVEN download the (protected) files? (and the resource file isnt in http-client-files), im sure thats the reason why doesnt load the client the script ^^

Yooshi

2012-03-24 15:27

viewer   ~~0016365

Last edited: 2012-03-24 15:28

protected = "true" doesn't compile asturel. It only prevents to be downloaded to the player's hard disk ( as JR10 said ). The script is saved in the memory.

PhatLooser

2012-06-08 12:42

reporter   ~~0016775

The script is saved in the memory and still can be downloaded from the external http server.

arranTuna

2012-06-08 12:50

manager   ~~0016776

No it can't, it doesn't go in http-client-files it goes in http-client-files-protected and is downloaded using internal web server only.

ryden

2012-12-28 07:48

manager   ~~0017926

Please, re-test.

Issue History

Date Modified Username Field Change