View Issue Details

IDProjectCategoryView StatusLast Update
0006826Multi Theft Auto : San AndreasServerpublic2012-02-10 11:52
ReporterSebihunterAssigned Toccw 
PriorityurgentSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.1Fixed in Version1.3.1 
Summary0006826: Timeout on map change
Description

Since 1.3 many players on our server time out after a map change to a bigger map. Download has finished, you spawn and suddenly timeout.

Steps To Reproduce

Start a race server with big maps (filesize) and change maps. Many people will timeout after having downloaded the map.

TagsNo tags attached.

Activities

Feche

2012-01-25 17:47

viewer   ~~0015812

Yes it's annoying.

Sebihunter

2012-01-26 19:23

viewer   ~~0015828

Last edited: 2012-01-26 19:28

Revision 3747/3748 did not change anything. When testing I timeouted while downloading the map or better say the download stopped and did not continue for no reason.

ccw

2012-01-26 19:39

administrator   ~~0015829

This is definitely the map download and not resources download?
(The progress box will say 'Map' in it)

Sebihunter

2012-01-26 20:31

viewer   ~~0015831

Last edited: 2012-01-26 20:39

I guess it will be general resources but I am not quite sure. Atleast it happens at every map change in race.
I am currently observing it.

Edit:
It seems to fail at map download progress. At mapchanges (not @connect) the map loads like 100kB, then stops, then again 100kB. This goes on for some time but after some time it stops completely and times out.

TwiX73

2012-01-28 13:31

viewer   ~~0015876

I confirm it, because its bad
bug in 1.3
i'm optimize my scripts/change race gamemode to original, off my scripts
Just only "race" gamemode working
and when big map changed, all players - timedout, and ping +1000
with the new upgrade, nothing changed
Pls fix it

Feche

2012-01-28 16:17

viewer   ~~0015878

It is a map download problem, and not a resource problem. (Resources download great, fast and smooth. Maps download slow, freezing and with timeouts sometimes.)

TwiX73

2012-01-28 19:16

viewer   ~~0015885

on 1.2 no problems :/

Skotinka

2012-01-29 10:01

viewer   ~~0015889

i have the same problem in 1.3!!

LTWYD

2012-01-29 13:42

viewer   ~~0015890

I have the same problem. And I know from many other people that they have the same annoying problem.

Lexlo

2012-01-29 13:45

viewer   ~~0015891

Yea its annoying and should be fixed very soon...

drifterCZ

2012-01-29 14:58

viewer   ~~0015893

Steps to reproduce: Create a map with many many object - map file about 3MB and test it with more than 10 players

Skotinka

2012-01-30 17:39

viewer   ~~0015907

Last edited: 2012-01-30 17:39

When it will be fix ???

Feche

2012-01-31 23:17

viewer   ~~0015915

I'm not sure, but we have for a while until it's fixed.

drifterCZ

2012-02-03 10:33

viewer   ~~0015927

Last edited: 2012-02-03 10:37

Its most important thing to fix, more than anything else... Why MTA devs concentrate to less interesing task? At least just return the map downloading back to 1.2 style, if you cant fix the actual right now, and we would be happy

PhatLooser

2012-02-03 10:42

reporter   ~~0015928

Can't the maps be downloaded via TCP, I ask?

Skotinka

2012-02-03 12:13

viewer   ~~0015929

I think they it is not quick will fix

Sebihunter

2012-02-03 17:18

viewer   ~~0015932

I totally agree with Feche. It is a punch in the face of many server owners that people actually work on 1.4 or bugfixes for MTA 1.3 functions while there is a bug which splits the MTA:SA community into 2 parts. Many servers are not able to upgrade because ofthis and we literally get NO information about ANYTHING related to this problem. We do not even know if somebody is working on it, nor has it been set to confirmed after having it confirmed by many people here.

I am kinda disappointed.

Feche

2012-02-05 19:08

viewer   ~~0015946

2012-02-03 17:51 x86 Status new => confirmed

Looks cool.

Skotinka

2012-02-07 17:29

viewer   ~~0015967

yea... waiting when it fix!!

drifterCZ

2012-02-09 14:38

viewer   ~~0015994

major problem of 1.3 and still not assigned. sad

ccw

2012-02-09 19:14

administrator   ~~0016000

Please try Linux nightly server r3834 or later

Sebihunter

2012-02-09 20:29

viewer   ~~0016001

r3834 fixed that problem for us

Feche

2012-02-09 20:30

viewer   ~~0016002

Working like a charm, thanks!

drifterCZ

2012-02-09 20:31

viewer   ~~0016003

ccw: still the same, map download mostly slow as hell ~ 1kb/s

ccw

2012-02-09 20:36

administrator   ~~0016004

Fixed from server r3834

drifterCZ, it seems fixed for most others, so your problem could be something else. Please add a new issue with exact details

Sebihunter

2012-02-09 20:39

viewer   ~~0016005

Last edited: 2012-02-09 20:40

Map download is really slower than before but no timeouts on mapchange. Can confirm this drifter. Also the map download seems to be slow on nightlies as I am the only one to experience this - release builds seem to work fine.

Feche

2012-02-09 20:50

viewer   ~~0016006

Downloads on my server are much faster for all players.

drifterCZ

2012-02-09 23:31

viewer   ~~0016008

new report on http://bugs.mtasa.com/view.php?id=6876

Skotinka

2012-02-10 10:08

viewer   ~~0016017

now we tested, and it fixed, ty!!! )

Issue History

Date Modified Username Field Change