View Issue Details

IDProjectCategoryView StatusLast Update
0006813Multi Theft Auto : San AndreasClientpublic2013-06-01 17:04
ReporterBinSlayerAssigned ToCazomino05 
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.2Fixed in Version1.3.2 
Summary0006813: Bikes and boats gone wild
Description

This issue has been present since 1.2 but I was under the impression that http://code.google.com/p/mtasa-blue/source/detail?r=3595 was related. Now I'm not sure, so I'm opening up this bug report
So bikes and boats get bugged randomly, no way that I've found to reproduce.
They simply go crazy, they are unresponsive to control keys and they will warp all over the place. Bikes even go through the floor in a constant warping, while boats will only warp as much as they can until they're get in a 'sunk' position. It appears at the end of the video I'm attaching. It just leans on one side and stays like that no matter what control you press.
There's not much information I can give about the reproducibility but I can only show you what I'm talking about, so here's a short video of a boat gone wild
http://bbq.to/bikes_68dd.wmv
Note: I believe the only way to 'fix' it is to restart your MTA client, since it doesn't always happen

Steps To Reproduce

None

Additional Information

http://code.google.com/p/mtasa-blue/source/detail?r=3595

something similar at least, although it seems to refer to a crash?
I must also say that cars and planes work fine at all times.

TagsNo tags attached.

Activities

Cazomino05

2012-01-25 09:01

reporter   ~~0015805

Try in 1.3 I did at least 2 fixes on this code.

BinSlayer

2012-01-26 16:18

viewer   ~~0015826

Last edited: 2012-01-26 16:20

client: 3732
server: 3735

It still happens but in a new way. Now it simply freezes and I have to end the process when it happens, so you don't even get to play with your 'bugged' bike anymore

Cazomino05

2012-01-27 13:49

reporter   ~~0015852

Try again in the latest nightly

BinSlayer

2012-01-27 16:18

viewer   ~~0015863

Alright thanks, since the bug happens randomly I'll need time to test it as much as I can
I'll post again after a while if I won't have gotten any issues until then

Cazomino05

2012-01-27 16:19

reporter   ~~0015864

thanks, I'm expecting it's fixed now as I did try myself but couldn't reproduce it.

BinSlayer

2012-01-28 19:30

viewer   ~~0015886

Last edited: 2012-01-28 21:38

I just experienced the bug with a bike. So my bike started warping around through the floor for a few quick seconds and then it just fixed itself and it respawned on the ground so I was able to continue playing.

Short version: Bug happend again but fixed itself after few secs

edit: it's not actually a few seconds.. it happend again and it wouldn't stop warping the bike around san andreas for a longer while

BinSlayer

2012-01-29 14:08

viewer   ~~0015892

Also there's another thing with bikes. They don't warp(collisions for it are still enabled), but their handling is beyond control. I could press W and it would go to the right pretty fast as if handling was altered

MrMuLTiVaN

2012-01-30 09:11

viewer   ~~0015903

And you can fly with the bikes, and then you will be banned

BinSlayer

2012-01-30 16:35

viewer   ~~0015906

Last edited: 2012-02-10 21:02

@MrMuLTiVaN: Lol that's because the admins are unaware of the bug and mistake u for a cheater
It's not really related to the bug directly

MrMuLTiVaN

2012-02-04 19:07

viewer   ~~0015938

@BinSlayer yep, I got banned :D(-.-)

BinSlayer

2012-02-14 14:14

viewer   ~~0016065

Last edited: 2012-02-14 22:01

EDIT: Using v1.3-release-3845
I just got the bug with a bike.
I didn't do anything out of the ordinary I remember running a few sql queries but this is clearly trivial
Unfortunately the bug is not fixed yet

drifterCZ

2012-02-15 16:59

viewer   ~~0016078

Maybe interesting: GTASA.exe is using more than 1GB RAM in 99% cases when this bug appear.

So keep rejoining a lot, etc... until you pass over 1GB and it will sure appear.
Tested with r3858

ccw

2012-02-16 21:03

administrator   ~~0016085

Try turning down the cache size in Settings->Advanced. Does that make the bug appear sooner?

drifterCZ

2012-02-16 22:54

viewer   ~~0016086

Editing cache doesn't change anything.

I've rejoined various servers about 40 times, I pass over 1,1GB RAM and it appear again.

Required vehicle: as mentioned - bike or boat

There are 3 things which could happen:

  1. You start flying arround the whole map
  2. Game completely freezes - "it moves you so fast, that game can't handle it" (unfreeze after few minutes after you press enter=die in race gamemode)
  3. This: http://driftercz.mtasa.cz/bugs/3.png - "it moves you so fast, that game can't handle it #2"

When vehicle is froozen

BinSlayer

2012-02-17 16:13

viewer   ~~0016101

I couldn't have described it any better than you did, drifterCZ.
The bug is EXACTLY as mentioned by him (with the leaned bike, game freeze, bike flying around (boats too)

How can I see how much RAM the game consumes? I'll test this too, to see if getting > 1 GB really reproduces it.

drifterCZ

2012-02-17 16:15

viewer   ~~0016102

ctrl+shift+escape -> processes

BinSlayer

2012-02-17 20:00

viewer   ~~0016113

Last edited: 2012-02-17 21:50

Hm, yeah I think it's a pattern
I played a long time (1/2 hours) and I rejoined a few times and I crashed instantly when I rejoined + respawned and the map had a NRG-500 as spawnpoint.
I must say it only happend when the GTA memory usage was > 1.150.000 K
i.e a little over 1.1 GB

EDIT: Confirmed the steps to reproduce yet again.
Make sure your GTA memory is above 1.1 GB (something like 1.2 will do) and give yourself a bike using the admin panel. Insta-crash

ccw

2012-02-18 11:59

administrator   ~~0016116

Next time the bug happens type 'test ca' into the client console

BinSlayer

2012-02-18 15:21

viewer   ~~0016119

But the game freezes when this bug happens. (well 90% of the time it freezes)
Can't type anything if its frozen

ccw

2012-02-18 15:53

administrator   ~~0016120

Has the issue changed from the original description?

BinSlayer

2012-02-18 16:00

viewer   ~~0016121

Yes. In addition to the original descriotion, the bug can also freeze the game.
Read this, it's a part of a note posted by drifterCZ:
"There are 3 things which could happen:

  1. You start flying arround the whole map
  2. Game completely freezes - "it moves you so fast, that game can't handle it" (unfreeze after few minutes after you press enter=die in race gamemode)
  3. This: http://driftercz.mtasa.cz/bugs/3.png [^] - "it moves you so fast, that game can't handle it #2""

Originally, your bike would only warp/fly around. But since Cazomino's fix attempt, the bug also causes game freezes.

ccw

2012-02-27 18:48

administrator   ~~0016168

Try nightly from r3878 and put memory cache size at 128MB in Settings->Advanced.
And see how long it takes for GTA to use 1GB

BinSlayer

2012-03-16 19:30

viewer   ~~0016299

Haven't had a single crash since r3878
For all I know you could mark this as resolved
Thanks for the assistance devs!

x86

2013-05-23 11:44

administrator   ~~0018594

Still here ?

Cazomino05

2013-05-31 20:08

reporter   ~~0018620

in all honesty I have not had this in ffs racing since the last fix attempt so I'm setting this to resolved feel free to reopen this if it happens again

Cazomino05

2013-05-31 20:10

reporter   ~~0018621

was fixed before 1.3.2 but no idea when so set it to 1.3.2

Issue History

Date Modified Username Field Change