View Issue Details

IDProjectCategoryView StatusLast Update
0006799Multi Theft Auto : San AndreasClientpublic2012-03-21 02:30
ReporterTjongAssigned Toccw 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target Version1.3Fixed in Version1.3 
Summary0006799: Elements are randomly disappearing
Description

I'm currently working on a mode, where I delete the whole SA-Map and generate a new one.
Now I encounter problems with elements (mainly objects, but vehicles as well), which are randomly dissapearing when you turn your camera. I've attached two screenshots, where I'm just moving my camera and then the objects are dissapearing, sometimes they still have collision, sometimes they're completely gone (although they don't trigger Events like "onClientElementStreamOut")

The places where this occurs are very random because it happens on positions in SanAndreas and also at coordinates which are far away from the normal map. But they seem to be static so it always happens at the same position.

The elements are definitely really gone (at least temporary), because when I was flying with a helicopter, I was kicked out of the vehicle and fell down, although only moments later the helicopter appeared back again.

Steps To Reproduce

I don't know if this is reproducable in the normal SA World, although on my server you just have to drive along such random places which aren't really rare.

Additional Information

Two Screenshots showing the effect:
How it should look like: http://img6.imagebanana.com/img/qs9gq6ty/mtascreen_20120114_145347.png
Camera turned very little: http://img6.imagebanana.com/img/r6uzjaos/mtascreen_20120114_145343.png

TagsNo tags attached.

Activities

ccw

2012-01-19 22:24

administrator   ~~0015763

What coordinates did the helicopter disappear at?

Tjong

2012-01-19 22:40

viewer   ~~0015764

Last edited: 2012-01-19 22:40

Can't reproduce it in the moment, but I remember that the position was something like:

x = [-500,500] y = ~ 6000 z = ~ 70

Picard

2012-01-20 04:14

updater   ~~0015766

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=3714 )

dragonofdark

2012-01-27 18:22

viewer   ~~0015865

I don't know if it's the same thing, bug when I remove some originals objets, some others are randomly disappearing.

Screens (I removed the 2 builings in front of unity station):

http://img15.hostingpics.net/pics/328336mtascreen20120127180906.png
http://img15.hostingpics.net/pics/463215mtascreen20120127180856.png

dragonofdark

2012-01-27 18:23

viewer   ~~0015866

Detail for my last note : I have the last automatically nightly update of mta 1.3.

ccw

2012-01-27 18:48

administrator   ~~0015867

http://wiki.multitheftauto.com/wiki/SetOcclusionsEnabled

Try: setOcclusionsEnabled( false )

dragonofdark

2012-01-27 19:32

viewer   ~~0015870

Okay, didn't see that. Thanks

Tjong

2012-03-21 02:30

viewer   ~~0016340

this doesn't seem completely fixed:
fine: http://img7.imagebanana.com/img/6i4y9mvj/mtascreen_20120321_021625.png
camera turn: http://img6.imagebanana.com/img/1alxq93a/mtascreen_20120321_021634.png

location is SF airport so this may be related to the basement garage located there

my MTA version is 1.3

Issue History

Date Modified Username Field Change