View Issue Details

IDProjectCategoryView StatusLast Update
0006795Multi Theft Auto : San AndreasServerpublic2012-02-28 09:15
ReporterBinSlayerAssigned Toccw 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.1Fixed in Version1.3.1 
Summary0006795: Downloading resource files breaks often
Description

In our race server, when a map starts that has huge custom stuff to download like sound files or txd/dff files of about > 6 MB, the download will perhaps reach halfway until a Network Trouble pops up and disconnects everyone with a "Connection to the server lost" message. The server becomes unconnectable for as long as it takes to boot everyone from it that were downloading files. After a while, you can reconnect and the download (previously started) will restart and work fine this time. So the issue only happens when more people are downloading at the same time (i.e map changes, everyone requests the files).
When this issue happens, of 70 players 30 or 40 will get disconnected which makes it a pretty serious issue.
My assumption is that when there is a high-volume of download requests the server stops sending data to the client (thus getting network trouble)
There has also been another issue of server not sending data but I have no idea if they are related: #6609
I must mention that if the map does not have any custom stuff to download then everything works fine and nobody gets booted.
Also it seems that the reason why it doesn't happen much with lower-sized downloads is that while Network Trouble would still pop up for a second there, the download gets finished quite fast and sync is restored between server <-> client
Furthermore, using an external web server for handling downloads does not fix this.
We're getting the issue both with and without the webserver

PS: At first I thought that this issue was related to the one about Map Download breaking often which was fixed but it appears that it isn't.

Thank you for your time

BinSlayer

TagsNo tags attached.

Activities

BinSlayer

2012-01-14 16:18

viewer   ~~0015739

We also tried using this like some people suggested
<httpmaxconnectionsperclient>1</httpmaxconnectionsperclient>

Still the same issue

arranTuna

2012-01-14 16:36

manager   ~~0015740

You've got 6mb maps and 70 players? So thats 420mb. Is the external web server hosted on the same connection?

Straight

2012-01-15 02:21

viewer   ~~0015744

http://www.youtube.com/watch?v=zFiplMHO1z4

this is the problem X.x

BinSlayer

2012-01-16 18:34

viewer   ~~0015752

Last edited: 2012-01-16 18:34

I don't know what that video is actually showing, but that's not the bug
the download just halts halfway with a network trouble and shortly after, it disconnects the player. I can't see that happening in your video

ccw

2012-01-16 18:46

administrator   ~~0015753

Last edited: 2012-01-16 18:47

Straight, that is a map download. (It says so in the progress bar) See #6796

This issue is to do with resource downloading.

Ywa

2012-01-22 20:16

viewer   ~~0015783

Bug 0006796 is unrelated. The actual problem happens BEFORE the downloading starts for clients. It happens when the server is changing the map/race. When the actual download starts for clients, the problem isn't there anymore.

Also, it happens on maps without any additional downloading too.

BinSlayer

2012-01-26 20:35

viewer   ~~0015832

Download breaking + getting booted seems fixed in 1.3
However, people still get a network trouble for 1-2 seconds and then it goes away
This is unrelated to resource downloads, but to map changes in general

Straight

2012-01-27 18:58

viewer   ~~0015868

sometimes i get timedout if i load ..

BinSlayer

2012-01-27 19:02

viewer   ~~0015869

Confirm 1.3 fixed it.
Haven't had a single mass timeout ever since
Ignore what I said about network troubles (totally unrelated to this)

Issue History

Date Modified Username Field Change