View Issue Details

IDProjectCategoryView StatusLast Update
0006793Multi Theft Auto : San AndreasServerpublic2012-01-26 20:58
ReporterKernellAssigned Tokevuwk 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.1Fixed in Version1.3.1 
Summary0006793: setElementDimension dont work for element tree
Description

setElementDimension has no effect for child elements

TagsNo tags attached.

Activities

arranTuna

2012-01-13 01:01

manager   ~~0015718

Why are you trying to setElementDimension on an element tree, instead of using a for loop of getElementsByType?

Kernell

2012-01-13 08:42

reporter   ~~0015719

Last edited: 2012-01-13 08:46

Optimization, and usability.

Example: i changed interior for player - interior for child elements also changed (attached weapons, ...)

Kernell

2012-01-13 11:52

reporter   ~~0015720

arranTuna,
you probably are not familiar with the element tree?

arranTuna

2012-01-13 12:42

manager   ~~0015721

http://wiki.multitheftauto.com/wiki/GetElementChildren

Loop that then.

Kernell

2012-01-13 15:21

reporter   ~~0015722

Last edited: 2012-01-13 15:24

I am not idiot, and i know this function. You carefully read comment #2?
Are you looking for an excuse to not fix the bug.

setElementInterior, setElementAlpha and etc - normal working on element tree, but not setElementDimension

I didn't ask you how do I work around a bug. I'm telling you that you have a bug and it should fix it!

ryden

2012-01-26 20:40

manager   ~~0015833

We are not gonna not fix a bug just because there are workarounds.

kevuwk

2012-01-26 20:58

administrator   ~~0015834

should now run on children

Issue History

Date Modified Username Field Change