View Issue Details

IDProjectCategoryView StatusLast Update
0006786Multi Theft Auto : San AndreasClientpublic2012-09-26 14:10
ReporterBinSlayerAssigned Toccw 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.2Fixed in Version1.3.2 
Summary0006786: setFarClipDistance messes with water drawing
Description

Seems like a far clip distance above 4000 has an unwanted effect on water. If you look away from land then the water visually disappears. However, it comes back if you look at the city again. Not sure if this is a pattern but that's how I reproduced it.

It sucks because it always happens in maps that are built away from San Andreas

I made two pictures showing how simply rotation the camera toggles the bug

http://bbq.to/away_a6cb.png
http://bbq.to/tocity_867b.png

Steps To Reproduce

^

TagsNo tags attached.

Activities

CWanted

2012-09-24 12:53

updater   ~~0017622

Does this still happen?

StifflersMom

2012-09-24 19:08

updater   ~~0017624

Yes.

http://youtu.be/DaYHGT7ZPQo

clientside: setFarClipDistance(4000) , setFogDistance(1000), for reproducing you do not need fog distance.

Tested with 1.3.1-9.04707.0

ccw

2012-09-26 08:00

administrator   ~~0017629

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=4719

Works up to 9000 now

Issue History

Date Modified Username Field Change