View Issue Details

IDProjectCategoryView StatusLast Update
0006754Multi Theft Auto : San AndreasServerpublic2012-01-24 19:44
ReporterarranTunaAssigned Toccw 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3Fixed in Version1.3 
Summary0006754: Crash when turning threadnet off
Description

^

TagsNo tags attached.

Activities

x86

2011-12-26 11:27

administrator   ~~0015519

Please provide more information instead of "^".

i.e.

  • How to reproduce ?
  • When does it happen ?

arranTuna

2011-12-26 13:02

manager   ~~0015521

srun setServerConfigSetting("threadnet", 0)

I suppose it needs players, I haven't tried on an empty server. It happened twice when I tried twice.

TreN

2011-12-26 14:40

viewer   ~~0015522

Last edited: 2011-12-26 14:41

Confirmed on local server.(1 player ; r3854) I runcode'd Arran's example several times(in game) :
srun setServerConfigSetting("threadnet", 0)
srun setServerConfigSetting("threadnet", 1)
srun setServerConfigSetting("threadnet", 0) - crash on this action(or maybe 1,0,1)

Server dump file : http://www.mediafire.com/?2ws2o9rx26a522o

x86

2011-12-27 20:28

administrator   ~~0015545

In my eyes, it's not recommended to change threadnet value in-game (or to play with it), since it have to setup some (big) things (i.e. threads).

arranTuna

2011-12-27 20:34

manager   ~~0015546

There must be code that was added to handle it being turned on and off with this function, disabling this functionality would be fair.

Picard

2011-12-28 10:25

updater   ~~0015550

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=3597 )

Issue History

Date Modified Username Field Change