View Issue Details

IDProjectCategoryView StatusLast Update
0006744Multi Theft Auto : San AndreasServerpublic2012-02-24 12:39
ReporterFunGtAssigned Tokevuwk 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.3.1 
Summary0006744: Possibility to flag (required/optional) the files to download from the servers
Description

I was wondering if is possibile to add the following feature.
When you join in a server there are a lot of MB to download, but most of the times these files are NOT required to run the gamemode/map. For examples the music or the custom sounds should be flagged by the server/author as a OPTIONAL download, so you can choose or not to download it. On the other hand, a required download will be downloaded automatically.

TagsNo tags attached.

Activities

LooooP

2011-12-22 19:00

reporter   ~~0015470

Nice, I support this idea

W

2011-12-22 19:52

viewer   ~~0015477

Last edited: 2011-12-22 19:55

It can be accomplished with scripting (onClientResourceStart + triggering server event + managing list of optional/mandatory client resources on server side).

Although having a way to alter order of resources to download would be nice, indeed.

arranTuna

2011-12-22 19:55

manager   ~~0015479

You wouldn't be able to set one file as optional but the whole resource because almost every script would break if it started with stuff missing.

Model replacement script that starts before the files are there.
Images for GUI's would break
Images for DX would spam debug errors until they're downloaded.
Any music that starts on resource start would fail.

kevuwk

2012-02-24 12:39

administrator   ~~0016154

see downloadFile, onClientFileDownloadComplete and the <file> tag in meta.xml on the wiki for further info

Issue History

Date Modified Username Field Change