View Issue Details

IDProjectCategoryView StatusLast Update
0006726Multi Theft Auto : San AndreasClientpublic2012-01-24 19:44
ReporterTreNAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindows 7OS Version
Product Version 
Target Version1.3Fixed in Version1.3 
Summary0006726: Server with more than 300 players or less disappears from server browser and favourites
Description

^Server with more than 300 or less players disappears from server browser and favourites
Server doesn't appear in Favourites list and it disappears from server browser with message ..loading.. in nickname tab
Screen: http://savepic.net/2249122.jpg
In Favourites it's just don't display.

TagsNo tags attached.

Relationships

related to 0007000 closed New issues [Serverbrowser] Unable to see all players connected 
related to 0006776 closed New issues 'Players' alphabet returning empty lines 

Activities

Zango

2011-12-17 15:23

viewer   ~~0015387

I'm pretty sure this is because of lag. When the server is under high load it doesn't seem to feed the master servers with any data and the server disappears briefly. I don't think this is necessarily related to servers with a lot of players, I've tried this at 70-80 players under heavy lag.

arranTuna

2011-12-17 15:28

manager   ~~0015388

I've had this before too, servers disappearing even though displaying fine in favourites tab.

arranTuna

2011-12-17 15:59

manager   ~~0015391

I'm getting this right now too. CIT server appears but with no ping listed and ..loading.. player list then vanishes, yet connecting through IP works perfectly.

Server FPS is like 80 so I don't see any high resource usage reason to cause this and there is at least 30 mbits available for server browser.

ccw

2011-12-17 21:52

administrator   ~~0015393

When a server has more than 200-300 players its query response won't fit into one packet anymore, so it sends two. If either one gets lost, then the packet is ignored.
Also, some firewalls will block these 'fragmented' packets
e.g. Comodo (Firewall Behavior->Advanced->Block Fragmented IP datagrams)

arranTuna

2011-12-18 19:48

manager   ~~0015401

Maybe only show enough players in the list that fit into 1 packet then? Doesn't look like another solution.

Picard

2011-12-29 02:56

updater   ~~0015556

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=3604 )

Issue History

Date Modified Username Field Change