View Issue Details

IDProjectCategoryView StatusLast Update
0006685Multi Theft Auto : San AndreasServerpublic2013-02-05 20:52
ReporterKenixAssigned ToKenix 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.2Fixed in Version1.3.2 
Summary0006685: request function getEventHandlers
Description

request getEventHandlers for check if event handler added for element

TagsNo tags attached.

Relationships

child of 0003344 closed New Feature Requests Requested features tracker 

Activities

ryden

2011-11-26 19:07

manager   ~~0015285

In any case, it should be called getEventHandlers.

MX_Master

2012-02-04 07:30

viewer   ~~0015935

right, getEventHandlers will be useful. But this function must returns table only with functions of current resource

Kenix

2012-02-04 13:48

updater   ~~0015937

Last edited: 2012-02-04 13:50

table getEventHandlers( resource )

MX_Master

2012-02-04 19:09

viewer   ~~0015939

Last edited: 2012-02-04 19:18

you forgot event name ^^

table getEventHandlers ( string event, resource fromResource = resource )

may be will be useful also

table getEvents ( string type = 'all', resource fromResource = resource )

type: 'all', 'build-in', 'own'

Talidan

2012-02-05 12:47

administrator   ~~0015945

You can't get function types from other resources due to limitations in VMs. Would have to be getEventHandlers ( string event )

mabako

2012-02-06 20:07

updater   ~~0015958

That might be better if it'd return the event handler specifically bound to one element.

addEventHandler( "onClientPoop", localPlayer, fn )
getEventHandlers( "onClientPoop", localPlayer ) returns {fn}

Kenix

2013-02-03 01:56

updater   ~~0018100

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=4973

Issue History

Date Modified Username Field Change