View Issue Details

IDProjectCategoryView StatusLast Update
0006635Multi Theft Auto : San AndreasClientpublic2012-09-20 22:06
ReporterNeO_D-PowerAssigned Toccw 
PrioritynormalSeverityblockReproducibilitysometimes
Status resolvedResolutionfixed 
PlatformMicrosoft WindowsOSWindowsOS Version7 X64
Product Version 
Target Version1.3.2Fixed in Version1.3.2 
Summary0006635: Bikes and RC Bandit sometimes randomly bounce off the ground once their wheels touch the surface (roads, water, ground, etc)
Description

Bikes and RC Bandit sometimes bounce off the ground once their wheels touch the surface (roads, water, ground, etc) and the force varies from time to time: from violent warping to mild sliding/dragging across the surface.

If these vehicles warp away too fast and there is a local player (or a player that you spectate) attached to that vehicle - game freezes or even crashes and the only way to exit the game is the termination of the game process (gta_sa.exe), that is why I think this belongs to "block" category.

This bug also appears to be strictly client-side and can be triggered with setElementModel or createVehicle.

Reconnecting to a server or connecting to another server does not appear to solve this problem.

Steps To Reproduce

No definite steps to reproduce - keep trying to spawn a bike or a RC Bandit multiple times; may even have to restart the game and repeat the process.
Best gamemode to observe this bug - Race with maps that have bike/RC Bandit vehicle change pickups or spawnpoints.

Additional Information

Three videos from MTA 1.1.1:
http://www.youtube.com/watch?v=LP31WygIAa4
http://www.youtube.com/watch?v=S9HGZmaMT1o&feature=related
http://www.youtube.com/watch?v=Le2BX3oOR48&feature=related

TagsNo tags attached.

Users sponsoring this issue
Sponsors List Total Sponsorship = EUR 10

2012-05-26 13:49: arranTuna (EUR 10)
Users sponsoring this issue (Total Sponsorship = EUR 10)

Activities

Cazomino05

2012-01-04 05:51

reporter   ~~0015596

Retest with at least r3636

NeO_D-Power

2012-01-12 03:47

viewer   ~~0015711

Still occurring in r3644 although less often than it used to... =/

Cazomino05

2012-01-17 13:04

reporter   ~~0015754

Possibly fixed in 1.3 r3692 if this isn't so please post feedback here

arranTuna

2012-05-26 13:50

manager   ~~0016698

Happens with all vehicles AFAIK and its something which happens often.

PhatLooser

2012-05-26 21:50

reporter   ~~0016702

Last edited: 2012-05-26 22:25

sometimes able to reproduce with a lot of forwardClient().

€dit:
Redirecting a player for several times seems to speed up the issue.

ccw

2012-05-26 21:56

administrator   ~~0016703

What is forwardClient() ?

PhatLooser

2012-06-08 20:39

reporter   ~~0016784

(redirectPlayer, not forwardClient)

Also, it seems to depend on the position and rotation of the RC/bike. Sometimes it happens that, if you warp to the mainland, you can drive without a bug for a while, then suddenly (if you reach a certain spot) you will start flying again.
Especially if you break the 3000 unit boundary.

PhatLooser

2012-06-11 23:02

reporter   ~~0016808

Now, it just happened again. And again I was able to stand still on the mainland for a while, until I tuned my acceleration a bit (original acceleration * 1.25), and suddenly it happened again. Could it be that its a wrong software pointer?

JoeBullet

2012-06-11 23:04

updater   ~~0016809

Can you please test this with the latest nightly?

Cazomino05

2012-06-19 16:10

reporter   ~~0016845

what he said ^

CWanted

2012-06-19 19:09

updater   ~~0016846

http://bugs.mtasa.com/view.php?id=5318
I guess this is related.

Cazomino05

2012-06-19 19:15

reporter   ~~0016848

na it seems unrelated could someone test this specifically because I think it's fixed, r4224 or greater.
if it's fixed thank JoeBullet
if not it's lil_Toady's fault

PhatLooser

2012-07-05 19:10

reporter   ~~0016972

I cannot reproduce it with the latest nightly RC for now, but I'll go on trying for a while.

Issue History

Date Modified Username Field Change