View Issue Details

IDProjectCategoryView StatusLast Update
0006622Multi Theft Auto : San AndreasServerpublic2018-02-21 00:21
ReporterWAssigned ToTalidan 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.5.3 
Summary0006622: water elements are dimensionless
Description

Water element doesn't change it's dimension when setElementDimension is used. Probalby the same applies to interior.
It would be nice to have it possible.

Steps To Reproduce

water=createWater(....)
setElementDimension(water,69)

TagsNo tags attached.

Relationships

related to 0004892 closed Multi Theft Auto : San Andreas Water Elements Are Unable To Change Interiors 
has duplicate 0009120 closed New issues Water elements are dimensionless 

Activities

lopezloo

2012-04-07 15:13

developer   ~~0016432

Confirmed. btw. all GTA water in map area are only visible in interior 0 but water outside area are visible in interior 0 and 5 (MaddDogg mansion with pool).

qaisjp

2014-11-16 01:38

administrator   ~~0022398

Note:
run water.dimension = 1
run water.dimension

0

Midzi

2016-01-24 23:36

viewer   ~~0024350

And when it can be repaired? Its very important because this bug prevents from doing many systems.

qaisjp

2016-07-21 15:41

administrator   ~~0024961

See https://github.com/multitheftauto/mtasa-blue/commit/ee902f59f3e5e27b43645c4d2ebd67eca423ba13

Build info: https://buildinfo.mtasa.com/?SHA=ee902f59f3e5e27b43645c4d2ebd67eca423ba13

Issue History

Date Modified Username Field Change