View Issue Details

IDProjectCategoryView StatusLast Update
0006621Multi Theft Auto : San AndreasClientpublic2012-02-29 00:14
ReporterMaccerAssigned Tokevuwk 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.1Fixed in Version1.3.1 
Summary0006621: Using setPedAnimationProgress Incorrectly Yields A Crash + Other Problems
Description

A multitude of bugs with the function. We should have tested this more carefully.

Steps To Reproduce

1.) CLIENT-SIDE: setPedAnimationProgress ( localPlayer, 0.5 ) -- Yields 0xC0000005
2.) CLIENT-SIDE: setPedAnimationProgress ( localPlayer, "wank_in", 0.5 ) -- Yields false even when it works.
3.) SERVER-SIDE: setPedAnimationProgress ( Player, 0.5) -- Always yields true.
4.) SERVER-SIDE: setPedAnimationProgress ( Player, "wank_in", 0.5) -- Always yields true, even when it doesn't work.

TagsNo tags attached.

Activities

arranTuna

2011-10-30 00:33

manager   ~~0015158

#1 Confirmed.
#2 Worked? Didn't for me.
#3 Confirmed.
#4 Confirmed.

kevuwk

2012-02-28 14:50

administrator   ~~0016173

looks to be a lot of issues around this, a quick look shows that 2 can never return true and 3 and 4 will always return true if you provide at least 2 arguments

kevuwk

2012-02-29 00:14

administrator   ~~0016177

fixed problems that can be fixed, if the correct parameters are provided to the server function then it can only return true as it is unaware of the animation currently being run by the ped

also updated wiki page

Issue History

Date Modified Username Field Change