View Issue Details

IDProjectCategoryView StatusLast Update
0006597Multi Theft Auto : San AndreasServerpublic2011-11-30 19:13
ReporterarranTunaAssigned Toccw 
PriorityhighSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target Version1.2Fixed in Version1.2 
Summary0006597: Actually save data to registry.db and internal.db
Description

So when the server crashes or its closed down without using shutdown we don't lose months of data because it hasn't even been writing any data to the file.

This used to happen a lot with account data, we had to start using MySQL just because the MTA database wasn't saving. Would save a lot of problems for other servers if this problem with databases is fixed.

TagsNo tags attached.

Activities

qaisjp

2011-10-09 21:34

administrator   ~~0015062

So what you mean is, the database data is only stored into the file (not flushed, just in ram) when the server is shutdown using a normal way?

arranTuna

2011-10-09 21:37

manager   ~~0015064

Yes but this doesn't always happen, it may be a matter of weeks/months of up time before it stops updating to hard drive.

ccw

2011-10-24 05:21

administrator   ~~0015129

I would like to think this is now fixed after updating sqlite.

Cazomino05

2011-10-24 11:44

reporter   ~~0015131

me too, the theory is if you END TRANSACTION which is an alias for COMMIT it sends the data to be saved

Issue History

Date Modified Username Field Change