View Issue Details

IDProjectCategoryView StatusLast Update
0006589Multi Theft Auto : San AndreasClientpublic2012-01-24 19:44
ReporterWAssigned Toccw 
PriorityimmediateSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3Fixed in Version1.3 
Summary0006589: Map download breaks often on large transfers
Description

When downloading large maps, progress often halts, while transmission is still taking place. Looks like failing retransmission-mechanism fail.

Screencast ilustrating this issue: http://fullserver.eu/pio/tmp/out-4.ogv

Notice, that even though the map download stalled, transmission is still taking place (RX counter in background).

Steps To Reproduce
  1. Load few megabytes of objects
  2. Connect to server
Additional Information

Packet dump collected during making this screencast: http://fullserver.eu/pio/tmp/pcap.bz2
Generated with: tcpdump -i usb0 -n -X -s -0 host <server-ip> -w pcap

  • This isn't related to MTA running under WINE. I can still reproduce it under real windows machine.
  • I guess this is related to packet loss/duplicate packets as I can reproduce this almost always (95% of time) on mobile cellular 3G/HSDPA connection, but very rarely on regular cable connection.
TagsNo tags attached.

Activities

LooooP

2011-10-08 22:15

reporter   ~~0015051

Last edited: 2011-10-08 22:16

Happens to me too (Cable connection) but also with small maps.

Download broke:
http://www.baixa.la/arquivos/4045486_imagem.png

After around thirty seconds I was disconnected:
http://www.baixa.la/arquivos/4362586_imagem.png

MTA:SA 1.1.1 r3273
MTA:SA Server 1.1.0 r3055 (Don't be happy, also happens on servers running 1.1.1)
Race gamemode [destruction derby], as you can see

John_Michael

2011-10-08 22:53

viewer   ~~0015052

I can ONLY reproduce this on one server ( Full Theft Auto, where I'm one of the developers -.-). I've updated the server to the latest linux release, and am using the latest nightly. Me and ccw have talked on IRC many times trying to find solutions for this. There are currently 3 other players that also report not being about to connect.

ccw

2011-10-09 08:12

administrator   ~~0015053

Thanks for infos.
As W said, it's probably MTA handling packet loss incorrectly.

I'm working on it, but no fix yet.

LooooP

2011-10-09 18:00

reporter   ~~0015059

May can help
netcdebug file (network encryption off):
http://www.mediafire.com/?7jjh7sefsootxsh

netcdebug file (network encryption default) Played for a while but got disconnected after a download break:
http://www.mediafire.com/?avkswmf4bbaz4yz

MTA:SA Server 1.1.1 r3259
MTA:SA 1.1.1 r3273
Race gamemode (destruction derby)
ADSL 1mbps (120kb/s download | 40kb/s upload)
Siemens Gigaset 201A

LooooP

2011-11-15 20:04

reporter   ~~0015238

Come on!!!

W

2011-11-16 18:15

viewer   ~~0015241

Workaround: limiting ingress traffic fixes the problem.

Shell script for limiting inbound traffic under modern Linux: http://pastebin.com/C9idCJGZ
The same should be possible under Windows in some other way.

Maybe problem is related to packet loss, not reordering?

x86

2011-11-23 15:14

administrator   ~~0015266

Probably fixed, retest

LooooP

2011-12-05 20:55

reporter   ~~0015335

Still can reproduce (MTA:SA 1.2.0-unstable r3516)

Straight

2011-12-13 20:15

viewer   ~~0015361

same problem what i can do ..

LooooP

2011-12-13 22:00

reporter   ~~0015363

^ Hope for a fix

Straight

2011-12-13 22:08

viewer   ~~0015364

Oke friend °.°

TreN

2011-12-14 09:44

viewer   ~~0015368

Guys,you can reproduce this on yours local servers? If yes,try to enable something in mtaserver.conf.Find a line and set to maximum :
<bandwidth_reduction>maximum</bandwidth_reduction>
Try connecting...
Anything changed? (of course server and client must be 1.2) Or maybe this line is not related to problem.

LooooP

2011-12-14 12:39

reporter   ~~0015371

^ This problem doesn't happens on local servers, only on remote servers.

Straight

2011-12-17 15:37

viewer   ~~0015390

Last edited: 2011-12-17 15:37

it does work at 1.0.5 but on 1.1 idk --

W

2011-12-20 08:58

viewer   ~~0015432

Last edited: 2011-12-20 08:58

Looks fixed for me, I connect succesfully each time and cannot reproduce it anymore in the same circumstances that were describe in bug report.

Using MTA 1.2 release version.

LooooP

2011-12-20 14:47

reporter   ~~0015440

I still can reproduce this

BinSlayer

2011-12-20 15:03

viewer   ~~0015441

Last edited: 2011-12-20 15:07

it happens often in servers with a bunch of players like 50+ or so.
it doesn't matter the size of the download, it can break with 3 and it can break with 10.
People's download halts and after a few seconds they get disconnected saying "connection lost"
The server is un-connectable for the client for a few seconds afterwards (just as long as everybody who had this issue gets booted) and then you can connect and the download will go as planned (being a lower total player count like 30 or 35)
That's how I would describe the steps to reproduce. And it still happens in 1.2.0 stable version
edit: probably it's worth mentioning that it doesn't happen to everybody at the same time. let's say a server has 50 players. 15-20 will get this issue while the rest will not notice anything wrong

W

2011-12-20 19:04

viewer   ~~0015446

Last edited: 2011-12-20 19:07

I withdraw my last statement, problem persists :/
Limiting incoming bandwidth helps.

@BinSlayer I'm pretty sure you're describing some other bug, related to downloading started resource by already connected players. This is handled by completely different mechanism than downloading map (objects) on initial connection (before downloading the resources).

FunGt

2011-12-22 19:46

viewer   ~~0015475

It happends a lot of times, like BinSlayer described! While you are downloading, suddenly you lost connection! I noticed also that in that time you have a very high ping (more than 5k). Fix asap!

LooooP

2011-12-27 00:54

reporter   ~~0015526

Last edited: 2011-12-27 13:48

I've talked with ccw and he told me he's working on it, but doesn't know what is causing it yet (So no progress at least for now, I guess).

SAES>Steve

2011-12-27 01:15

viewer   ~~0015527

Last edited: 2011-12-27 17:25

Can still reproduce it for me. Only time I am able to get in a server with a large download is if the server has approximately 15 or 20 people in it.

After doing /shownetstat 1 in-game, I've noticed that my ping will skyrocket to around 4000 or so, and the bytes received will be constantly moving, you normally can get to around 26 or 27mb then MTA will crash.

Hope any of this info helps. Would really love to get back in game :)

SAES>Steve

2011-12-27 17:27

viewer   ~~0015538

And just remembered something that may help:

This is what my MTA was doing when 1.1 was first released with the weird networking/downloading problem. Symptoms above in my last post would say about /shownetstat 1. I know there was a client fix for that; perhaps whatever the problem was with 1.1 could be the same for 1.2? Fix the same?

arranTuna

2011-12-27 17:27

manager   ~~0015539

Has anyone tried converting their maps to createObject and having them client side? It isn't a fix but it should work.

ccw

2011-12-27 17:28

administrator   ~~0015540

Next time it crashes, please copy the info from the crash dialog and post it here

LooooP

2011-12-27 17:33

reporter   ~~0015541

Has anyone tried converting their maps to createObject and having them client side? It isn't a fix but it should work.

Yes, it fixes the problem as the issue is only related with downloading of *.map files

SAES>Steve

2011-12-28 05:08

viewer   ~~0015547

Here's some screenshots, too long to type it all out.

First screenshot of the client attempting to download the resources:
NOTE the bytes received.

http://i817.photobucket.com/albums/zz91/TheSteveLawrence/MTA-downloading.png

Second screenshot of the client timing out and unable to download them.
NOTE: The resource changes each time it times out. When the resource has been manually downloaded and installed, it still displays a different resource.

http://i817.photobucket.com/albums/zz91/TheSteveLawrence/MTA-error.png

Any time I do have luck getting in, its because the playercount is average 20 or so. Sometimes I cannot even get in with that playercount and I end up getting what's above.

ryden

2011-12-30 03:18

manager   ~~0015563

Please, retest in the latest 1.3 nightly.

ryden

2011-12-30 04:00

manager   ~~0015564

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=3610

Cazomino05

2011-12-31 22:03

reporter   ~~0015569

Fixed after r3616 Update servers and clients!

Bober

2012-01-01 14:36

viewer   ~~0015573

No fixed ; /
server: r3620
client: r3626

Javier2409

2012-01-06 00:11

viewer   ~~0015636

i think i found what causes the bug (at least for me) because i had this bug but about one month ago my map downloads started to work fine, but here's the thing, my router closes ports after a period of time, and my ports are closed since one month ago, today i opened ports again and the bug came back.

ryden

2012-01-06 05:23

manager   ~~0015637

I can confirm that the sliding windows fix this.

SAES>Steve

2012-01-06 18:09

viewer   ~~0015649

Last edited: 2012-01-07 02:12

So tried Windowed Mode.... worked for me for about 2 or 3 times. Only on my laptop however, desktop showed the same symptoms and errors as it did before.

Laptop not working now either.

ryden

2012-01-07 03:10

manager   ~~0015657

Not windowed mode... sliding windows are a method of networking. They have been recently introduced into MTA, and not much servers support them right now. You'll have to wait until 1.3.

SAES>Steve

2012-01-07 04:06

viewer   ~~0015658

Alrighty then. :)

Feche

2012-01-08 18:46

viewer   ~~0015679

Last edited: 2012-01-09 19:46

I'm having it on 1.3 too.

EDIT:

Last release (Multi Theft Auto v1.3-release-3672) partially fixes the download bug with big maps. (The download has some freezes, but it completely downloads.)

ericksitox

2012-01-09 22:00

viewer   ~~0015684

with the rc 1.3-3673. it completed the download with big maps but the ping still going up like crazy :/

Feche

2012-01-10 17:47

viewer   ~~0015699

Last edited: 2012-01-11 13:30

You can see the freezes here:

http://www.youtube.com/watch?v=T7cmEQBQOck

EDIT:

I've just noticed something, the first time that you connect to the server and download the map, the download is fast and smooth, here is a vid:

http://www.youtube.com/watch?v=zFiplMHO1z4

Straight

2012-01-12 22:40

viewer   ~~0015716

this bug sucks really in 1.0.5 i didnt had it

LooooP

2012-01-13 15:21

reporter   ~~0015723

I've just noticed something, the first time that you connect to the server and download the map, the download is fast and smooth, here is a vid:

http://www.youtube.com/watch?v=zFiplMHO1z4 [^]

Exactly what I get here, the first time it finishes without any freezes, but then of the second time ahead it freezes (but still finishes, after much more time of course)

ccw

2012-01-13 21:23

administrator   ~~0015728

This issue has been resolved. Please open an new issue.

Straight

2012-01-22 12:10

viewer   ~~0015781

This bug is really annoying, when does 1.3 realease?

Issue History

Date Modified Username Field Change