View Issue Details

IDProjectCategoryView StatusLast Update
0006529Multi Theft Auto : San AndreasScriptingpublic2018-09-02 20:51
Reporter[PS]DazzaJay[AU]Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionsuspended 
PlatformPCOSXPOS Versionx64 Edition
Product Version1.1 
Target VersionFixed in Version 
Summary0006529: hedit Swinging_Chassis handling flag does nothing.
Description

This might not be the fault of hedit, might be an issue with the Swinging_Chassis Handling Flag itself.

But basically, Turning Off swinging chassis does nothing, neither does turning it on.

Video shows Turning it off in the Buffalo, and how it has no effect.
http://www.youtube.com/watch?v=Z3PMdpaPnLw

Steps To Reproduce

Get a Buffalo, open hedit, untick swinging chassis, Take it for a spin, Chassis still swings.

TagsNo tags attached.

Activities

Remi-X

2011-09-26 23:45

reporter   ~~0014941

Well, I doubt it's the cause of Hedit indeed, as the system works great. But there might be a possibility that I made a typo in the text, so it actually sets something else than the swinging chassis. Could you try to set it manually?

run setVehicleHandling ( getPedOccupiedVehicle ( getRandomPlayer() ), "handlingFlags", 0x???????? )

Replace the questionmarks with your handling.cfg handling flag, but keep the 0x in front of it ofcourse. If that works, it's my fault, I'll commit a fix within a few weeks together eith the new version of Hedit. Otherwise, it's a flaw in the handling manager of MTA.

Would be pretty weird if it's the handlingmanager though, as its all handled by a general function for handlingFlags, not individual for each byte and value.

Remi-X

2011-09-27 19:52

reporter   ~~0014950

Tested myself, it's the handlingmanager, not my handling editor.

run setVehicleHandling ( getPedOccupiedVehicle ( getRandomPlayer() ), "handlingFlags", 0x01708803 )

Just to mention, the first 0 disables the swinging chassis. There's no effect indeed.

BrianAndrews

2014-10-16 18:37

viewer   ~~0022181

Last edited: 2018-06-07 14:21

View 2 revisions

This is an issue related to many arguments of modelFlags and handlingFlags.

For example with handlingFlags I can modify width of wheels, make steering rear wheels but cannot change other stuff like "No handbrake" setting. I didn't use Hedit, I simply tested it using setModelHandling. Same applies to modelFlags.

function handlingChange()

    setModelHandling(578, "modelFlags", 0x20004008) -- DFT-30

end
addEventHandler("onResourceStart", resourceRoot, function() setTimer(handlingChange, 1000, 1) end)

The example above should apply double rear wheels to DFT-30. Instead nothing changes.

Issue History

Date Modified Username Field Change