View Issue Details

IDProjectCategoryView StatusLast Update
0006514New Feature Requests[All Projects] Generalpublic2018-09-30 14:28
ReporterarranTunaAssigned To 
PrioritynoneSeverityfeatureReproducibilityN/A
Status closedResolutionopen 
Summary0006514: Don't start Map Editor server if editor not found
Description

Some people install MTA and don't choose to install the resources and or the map editor. When they start Map Editor they end up with a black screen and the only information is in the console.

When they click "Map Editor" a check should be done to see if they actually have editor installed and if not tell them to reinstall MTA SA and do not deselect Map Editor, resources or however the installer works.

TagsNo tags attached.

Activities

eAi

2011-09-14 13:58

administrator   ~~0014782

Perhaps we should just force everyone to install the server and the editor - I'm fairly sure we did that for the initial 1.0 release after we realised this could be an issue.

x86

2011-09-14 14:03

administrator   ~~0014784

Yes, but still. What if they delete the map editor manually ?

arranTuna

2011-09-14 14:17

manager   ~~0014785

I tried to install just the client to see what happens. It seems that when you select to install only the client the server is still installed we just need to force editor to be installed too (I don't see any downside of it being installed) and I don't think many people will go to resources and delete editor then wonder why editor doesn't work.

CWanted

2014-03-16 15:02

updater   ~~0020395

The problem is partially fixed as MTA now has full installer. The only part left is displaying a warning about missing files.

Issue History

Date Modified Username Field Change