View Issue Details

IDProjectCategoryView StatusLast Update
0006492Multi Theft Auto : San AndreasClientpublic2014-06-27 19:23
ReporterNeO_D-PowerAssigned ToCazomino05 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
PlatformMicrosoft WindowsOSWindowsOS Version7 x64
Product Version 
Target Version1.4Fixed in Version1.4 
Summary0006492: Vehicles fall through the water without drowning and teleport to the nearest part of San Andreas
Description

Sometimes, vehicles (and possibly other elements?) fall through the water without drowning and then teleport to the nearest part of San Andreas' map as they reach the "floor" under water/seabed.

P.S. This is a very OLD bug, I am surprised that it has never been reported before.

Steps To Reproduce
  1. Start a race map, high above the water.
  2. Dive into the water.
Additional Information

It seems that attempts to increase the wave height also increases the chance of this bug happening, on the other hand, the length or velocity of the fall does not have any effect on this bug at all.
The issue seems to be very hard to reproduce.

This bug is rather annoying on DD/DM race-maps, as it allows people to escape the custom maps built above the sea and gain the unfair advantage over the other players. Race's "firewater" option has no effect as the vehicle that falls through the water does not trigger the explosion.

TagsNo tags attached.

Relationships

related to 0004175 resolvedCazomino05 Vehicles are randomly "moved"/respawned 
related to 0005233 resolvedCazomino05 Vehicle Falling off the map issue 
child of 0007809 resolvedCazomino05 [p] Vehicles fall through the map and lose their syncer 

Activities

Cazomino05

2013-09-02 10:39

reporter   ~~0019267

This behaviour won't change unless you want to fall through the map endlessly till you crash

Inspirator

2014-04-10 03:36

viewer   ~~0020646

Same thing happens if you set the wave height very high

Cazomino05

2014-06-27 19:22

reporter   ~~0021149

fixed in https://code.google.com/p/mtasa-blue/source/detail?r=6612

Issue History

Date Modified Username Field Change