View Issue Details

IDProjectCategoryView StatusLast Update
0006464Multi Theft Auto : San AndreasClientpublic2011-09-02 20:00
ReporterJohn_MichaelAssigned Toccw 
PrioritynormalSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
PlatformOSWindows 7OS Version
Product Version 
Target Version1.1.1Fixed in Version1.1 
Summary0006464: dxDrawImage width and height paramateres not working properly.
Description

The dxDrawImage width and height parameters seem to only be clipping the image, rather than scaling the image. This was a behavior that most scripts rely on.

Steps To Reproduce

While somewhat random, I have seen it in two places mainly: the killmessages resource, and our speedometer on Full Theft Auto.

Additional Information

While more efficient, the lack of scaling breaks a lot of scripts.

TagsNo tags attached.

Activities

DakiLLa

2011-09-01 22:31

viewer   ~~0014613

Confirmed. I have the same issue with the killmessages resource.

Gothem

2011-09-02 00:44

viewer   ~~0014615

Confirmed. This bug is present since the r3109 commit

MX_Master

2011-09-02 06:53

viewer   ~~0014617

Also confirmed with killmessages resource.

Picard

2011-09-02 09:46

updater   ~~0014621

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=3111 )

Issue History

Date Modified Username Field Change