View Issue Details

IDProjectCategoryView StatusLast Update
0006436Multi Theft Auto : San AndreasServerpublic2015-04-26 02:07
ReporterPhatLooserAssigned Toccw 
PrioritynormalSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
PlatformLinux ServerOSLenny 64 bitOS Version
Product Version1.1 
Target VersionFixed in Version 
Summary0006436: bugs in the maps object streamer server side
Description

The server is missing out some objects sometimes, like doors, walls, etc.
That results in a map loading only halfway.
Also, when you attach an object to another object and move it, the rotation sometimes gets messed up. In sth-DryDam this always seems to happen with the same object, so better try it out.

Steps To Reproduce

Run sth-Drydam.

To get missing objects, reload some other maps until objects are missing.
Trying to get a resource where always the same piece of wall is gone.

Additional Information

I'm trying to keep track of this

TagsNo tags attached.

Relationships

has duplicate 0006487 closed New issues Map Resource won't load correctly 
child of 0008840 closed Multi Theft Auto : San Andreas Object sync 

Activities

NeO_D-Power

2011-08-30 00:31

viewer   ~~0014540

I am not sure if it is related...
On my Race server we got an issue with objects getting respawned at a wrong rotation angle, which makes the map unplayable. Once the map resource is restarted, the problem is gone - these objects respawn properly until next time the map is played.
This doesn't happen all the time and I am unable to reproduce it - it is far too random.
The map file remains untouched and loads perfectly fine in editor, which rules out the file corruption.

PhatLooser

2011-08-30 00:32

reporter   ~~0014541

Its related.

hawk82

2011-08-31 02:13

viewer   ~~0014573

All the same. Noticed it happens with vgncarshade (ids 3458/8557) mostly.

PhatLooser

2011-08-31 11:59

reporter   ~~0014577

Last edited: 2011-08-31 12:00

Actually I think its happening with any object, but since carshade is the most-often used object in race maps it may look like its this object.
Are you sure its not just the fact that you are using a hell lot of vgncarshade's that makes this object the primary suspect?

NeO_D-Power

2011-08-31 14:05

viewer   ~~0014583

PhatLooser it's happening with any object.
Just had one of my RCG loops (using those road objects) ruined by this bug again.

arranTuna

2011-08-31 14:11

manager   ~~0014584

How do you know its server side, did you check with getElementPosition on both server and client?

NeO_D-Power

2011-08-31 16:05

viewer   ~~0014585

http://www.youtube.com/watch?v=-lJnOsH6vxY&hd=1 video showing the issue

ccw

2011-08-31 18:28

administrator   ~~0014590

Does every player see the exact same thing?
If you quit and rejoin the server, is the object still incorrect?

hawk82

2011-09-01 05:38

viewer   ~~0014602

Yes and yes.

NeO_D-Power

2011-09-01 07:01

viewer   ~~0014603

Yes, ccw.
I took that video after I reconnected.
You can clearly see that the player I was spectating also saw this object and that it was synced between us, also I can confirm that other 35+ players saw this.

PhatLooser

2011-10-19 13:24

reporter   ~~0015099

Last edited: 2012-02-02 23:48

Is this resolved?
I haven't had this bug in the newest version any more.

Seems to be resolved in 1.3.
Bug didn't appear to anyone in my community.

BinSlayer

2012-02-12 10:11

viewer   ~~0016049

Last edited: 2012-02-12 11:32

Actually 1.3 amplified it. It happens a lot more often than it did in 1.2 and earlier.
For some reason it happens a lot to the runway object which is used in many maps and sometimes acts as a bridge. 90% of the players will NOT collide with it (i.e they will go right through it) and they are unable to finish the map (They can see the object, just no collisions). A few select people usually won't get the bug and we pray that they win the map fast :P
If you quit and reconnect the bug is still there. If you restart the gamemode it seems fixed temporarily but then it happens again after a while

Also I tried forcing collisions on with setElementCollisionsEnabled and it's not working :P

EDIT: Restarting the gamemode actually fixes nothing. I just tested it.

EDIT2: Restarted MTA Client and joined the same server. The bug is gone now. So this means it's actually a client bug?

PhatLooser

2012-02-12 20:51

reporter   ~~0016053

Yes, you need to reset that element's collision.

ccw

2012-02-13 03:02

administrator   ~~0016055

The problem as show in NeO_D-Power's video was fixed in http://code.google.com/p/mtasa-blue/source/detail?r=3119

BinSlayer

2012-02-13 13:32

viewer   ~~0016056

Nice. What about object collisions going off (described in my note)? Any chance for a fix/workaround/whatever?

ccw

2012-02-13 19:40

administrator   ~~0016057

An issue for collisions not loading for some clients is here: #4455
Steps to reproduce would be awesome

BinSlayer

2012-02-13 20:20

viewer   ~~0016060

I don't think the player does something out of the ordinary when the bug happens, so steps to reproduce are nearly impossible to get. Especially because it happens to more people at the same time, but never to the whole server. 3 quarters of the server could have the bug and not be able to finish a map, while a few select people could be unaffected.

Might be best to release a nightly with debug stuff (if this is even possible) and next time it happens players can simply submit the debug log.
It will also take some time before we can get the bug again since no easy way to reproduce has been discovered

Issue History

Date Modified Username Field Change