View Issue Details

IDProjectCategoryView StatusLast Update
0006405Multi Theft Auto : San AndreasClientpublic2012-01-24 19:44
Reporterbug_Spanish4LifeAssigned Toccw 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3Fixed in Version1.3 
Summary0006405: Chinese/Japanese letters doesn't showing
Description

Chinese/Japanese letters appears as black-boxes.

Steps To Reproduce

outputChatBox( "????, ??, ??" )

TagsNo tags attached.

Relationships

has duplicate 0006550 closed Multi Theft Auto : San Andreas Chinese characters do not show correctly when typed 
child of 0006375 closed New issues Unicode issues 

Activities

bug_Spanish4Life

2011-08-25 18:23

viewer   ~~0014461

P.d: Letters doesn't showing here :/
http://translate.google.com/?hl=en&tab=wT#en|zh-TW|test
http://translate.google.com/?hl=en&tab=wT#en|ja|test
http://translate.google.com/?hl=en&tab=wT#en|zh-CH|test

nobita215

2011-09-04 18:31

viewer   ~~0014691

Yes, 1.1 official said support for Chinese, but in fact is not so, the chat window type in Chinese, the show in is not understand Chinese characters. Similar garbled, and the server console shows Chinese characters are also this kind of not understand Chinese character codes

Talidan

2011-09-04 20:48

administrator   ~~0014692

Last edited: 2011-09-04 20:49

Works fine here. Please pastebin your script.

Where are you guys from? Are you sure you have Chinese fonts installed on your system? You may need to install a unicode font like Arial Unicode MS. Check your settings in Control panel

Also, ensure your scripts are saved in UTF-8 or UTF-8 Without BOM.

Lastly, check your Console window (F8) to see what is shown there.

nobita215

2011-09-05 03:19

viewer   ~~0014698

My system is native Simplified Chinese WIN7, games and other software to display Chinese were normal, except the MTA, the input is obviously ??, out of the show in the MTA is not ha ha, but I have not seen the uncommon Chinese characters

nobita215

2011-09-05 03:21

viewer   ~~0014699

My system is native Simplified Chinese WIN7, games and other software to display Chinese were normal, except the MTA, the input is obviously ??, out of the show in the MTA is not ha ha, but I have not seen the uncommon Chinese characters

nobita215

2011-09-05 03:22

viewer   ~~0014700

Script with the MTA, is the official comes. Not been any changes.

nobita215

2011-09-05 03:57

viewer   ~~0014701

I found mta 1.0.5, the chat and can input Chinese characters display correctly. To 1.1.0 does not.

Talidan

2011-09-05 17:22

administrator   ~~0014712

Please can you check the following:

1) The behaviour of outputChatBox when you use a UTF-8 script
2) The input of Chinese into the client console (f8). Use the 'say' command to chat something into the chatbox.

In both cases, please provide screenshots of both the chatbox and the console.

Thanks

Bpb_Xommko

2011-09-07 10:34

viewer   ~~0014742

Last edited: 2011-09-07 10:42

In 1.1 they do. R you sure you have proper fonts?

And the proof is: http://rghost.ru/20722901/image.png. And I'm running Russian (!) Windows 7 x64.

bug_Spanish4Life

2011-09-09 18:26

viewer   ~~0014755

Seems to be mine bug....

nobita215

2011-09-10 06:37

viewer   ~~0014761

The game press T chat window open the window, in the Chinese, and eventually input display is not the same. Is similar to the Chinese characters displayed

nobita215

2011-09-10 06:38

viewer   ~~0014762

I want to ask the way
His latest SVN compiled the source code, and then select match of the.net. DLL launched the game but unable to connect their after compiled server. Tip TIME OUT. This is why. No official detailed development compiler SVN tutorial

Hyunsu2

2011-09-20 10:37

viewer   ~~0014835

When i type korean in chat, it's not correctly also.

ccw

2012-01-05 14:03

administrator   ~~0015623

Last edited: 2012-01-05 14:05

Hyunsu2 said in #6778:
"It had not been happend by MTA 1.0.5
but it has been happend since MTA 1.1.0

Now in MTA 1.2.0, Making Server that is written by korean is possible.
and all GUI is possible to be written by korean.

But only, Chatting is impossible.
because when i type korean in chatbox, the characters are broken(incorrect).

("outputChatBox" works well. ) "

ccw

2012-01-05 14:04

administrator   ~~0015624

Does using the console command 'say' also work?

Tim885885

2012-01-06 09:22

viewer   ~~0015638

Last edited: 2012-01-06 09:22

can't type chinese on 1.2
why 1.0.5 can type chinese on chat, but can't show chinese on menu.
now 1.2.0 can show chinese on menu, but can't type chinese on chat. o.O?

Tim885885

2012-01-06 09:25

viewer   ~~0015639

i tyep test test chinese word.
http://i.imgur.com/JS30t.jpg

can't work.
http://i.imgur.com/dSJjT.jpg

ccw

2012-01-06 09:42

administrator   ~~0015641

Sorry, I mean client console (F8)

Hyunsu2

2012-01-06 10:38

viewer   ~~0015644

Sorry, my report was wrong.

In MTA 1.0.5,
GUI can not be written by korean.
i can type korean in chat(not console)

In MTA 1.1.0,
GUI can be written
i can't type korean in chat.(console too )

In MTA 1.2.0,
GUI can not be written
i can't type korean in chat.(console too )

In all version,
outputChatBox works well
and letters written korean in chatbox are shown well.

Tim885885

2012-01-08 08:41

viewer   ~~0015674

Last edited: 2012-01-08 08:42

More Chinese Test,

on console.
http://imgur.com/Raruq

on outputChatBox etc.
http://i.imgur.com/DmwpE.jpg
http://i.imgur.com/F0jw6.jpg
http://i.imgur.com/zZvRg.jpg
http://i.imgur.com/mBlFA.jpg
http://i.imgur.com/4loZi.jpg

ccw

2012-01-10 00:30

administrator   ~~0015687

Please test client: http://updatesa.mtasa.com/sa/files/mirror/full/mtasa-1.3-rc.exe

Tim885885

2012-01-10 18:32

viewer   ~~0015701

can work chinese words on chat and client console (F8).
http://i.imgur.com/FVcxF.jpg
http://i.imgur.com/0YzaH.jpg

but can't show on server.
http://i.imgur.com/kxnx0.jpg

more test is come later.

ccw

2012-01-10 18:37

administrator   ~~0015702

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=3673

Server console issue is here: #6376

Tim885885

2012-01-10 19:34

viewer   ~~0015705

a lot test, chinese can't show on main menu, http://imgur.com/ll1U9

maybe somebody want to localization?

Issue History

Date Modified Username Field Change