View Issue Details

IDProjectCategoryView StatusLast Update
0006373Multi Theft Auto : San AndreasClientpublic2011-08-22 10:41
ReporterGamesnertAssigned Toccw 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0006373: Inability to use ' properly on certain keyboards
Description

The type of keyboard I use has a button for '. Pressing this button won't instantly print an ', but will rather wait for your next input character. For instance, if this is one of the following characters:

a
e
u
i
o
...

It will use the ' to make any of those a special character:

á
é
ú
í
ó

(If a space were to be pressed, it would just give you the ' character itself)

This won't work in MTA anymore though. Instead, it will just use the default character.

It gets even worse when using a character which is not compatible with this type of stuff. For instance, the "l". Pressing the ' and then the l will print l twice.

The only way of propperly getting the ' character to work is pressing ' twice, then pressing backspace once. This is kind of very annoying though.

All of the above also applies to characters like ", ` and ~.

Steps To Reproduce

Input: I'll übercharge
Ouput: Illl ubercharge

Additional Information

Started occurring after recent unicode changes.

TagsNo tags attached.

Relationships

related to 0006364 resolvedccw Multi Theft Auto : San Andreas [1.1] Auto complete in console adds last pressed button 
child of 0006375 closed New issues Unicode issues 

Activities

arranTuna

2011-08-16 18:50

manager   ~~0014310

Most likely caused by the recent fix for #5856 and then #6354 being the bug of created by #5856

Talidan

2011-08-16 21:19

administrator   ~~0014312

Last edited: 2011-08-16 21:21

What happens in the example:
Input: bábies

Also, do you know the name of these 'macro keys'? Need to find out how they work.

Gamesnert

2011-08-16 21:29

developer   ~~0014313

Apparently it's called a Dead Key

http://en.wikipedia.org/wiki/Dead_key

(And output would be "babies")

ccw

2011-08-21 22:19

administrator   ~~0014387

If this is still a problem, then we should revert 'Chinese letters on title bar' fix

medennis

2011-08-21 22:39

viewer   ~~0014389

This still happens for me, exactly as it says on steps to reproduce.

diegofkda

2011-08-21 22:41

viewer   ~~0014390

Last edited: 2011-08-21 22:46

Ah man, those characters are required for Spanish words.

EDIT: Also for Portuguese and others.

Hope this will be fixed.

Issue History

Date Modified Username Field Change