View Issue Details

IDProjectCategoryView StatusLast Update
0006368Multi Theft Auto : San AndreasServerpublic2011-08-16 11:25
Reporterhawk82Assigned ToCazomino05 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSWindows XP SP2OS Version
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0006368: addVehicleUpgrade (server-side only) doesn't work on vehicles whose models have been set from bikes to cars
Description

I noticed this on Race gamemode at first, when nitro pick-ups didn't do anything but make sound. When the players spawn with a bike (bicycle or motorcycle), even if their vehicle gets changed to a car (by taking a vehicle pick-up), they can't take nitro during the whole map. A further study showed that spawning a bike, setting its model to a car using setElementModel and then using addVehicleUpgrade on this car does nothing.

Steps To Reproduce
  1. Spawn a bike (Sanchez, NRG-500, BMX, etc.)
  2. Set its model to a car (Infernus) using setElementModel.
  3. Use addVehicleUpgrade on this car (try to add nitro or hydraulics).
Additional Information

Additional info:

  • Not only bikes, some aircraft (Shamals, but not Sparrows) also produce this bug.
  • Happens in all gamemodes.
  • addVehicleUpgrade works if you do it client-side, using the same steps as above.
  • At first, I noticed that nitro doesn't work and thought that it may be related to this: http://bugs.mtasa.com/view.php?id=6352
    but any upgrade I've tried didn't work.
TagsNo tags attached.

Activities

hawk82

2011-08-15 21:48

viewer   ~~0014295

Last edited: 2011-08-15 21:48

Update: I forgot to add that this didn't work since 2972 and even earlier versions, so I downloaded the first 1.1 available and noticed the same bug there.

Picard

2011-08-16 07:14

updater   ~~0014299

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=3007 )

Cazomino05

2011-08-16 07:15

reporter   ~~0014300

Vehicle type wasn't being reset and you can't upgrade those models with NOS etc :p

x86

2011-08-16 11:25

administrator   ~~0014303

Who introduced this problem ? svn blame please :D

Issue History

Date Modified Username Field Change