View Issue Details

IDProjectCategoryView StatusLast Update
0006352Multi Theft Auto : San AndreasClientpublic2011-08-21 16:40
ReporterGamesnertAssigned ToCazomino05 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0006352: Editing vehicle handling while NOS is enabled causes the vehicle to act weird
Description

If NOS is installed in the vehicle and enabled, any editing of the handling will cause the vehicle to handle entirely different.

Steps To Reproduce
  1. Spawn an Infernus
  2. /addupgrade 1010
  3. Active NOS
  4. F8 -> run setVehicleHandling(getPedOccupiedVehicle(getPlayerFromName("Yourname")),"maxVelocity",240)
  5. Try to drive. Note that 240 is the Infernus' default maxVelocity, and the handling should not have been changed. However, it has.
Additional Information
  • Nitro will disable when the handling is "changed"
  • Editing handling before enabling NOS will make the NOS impossible to enable
  • If NOS_INST is enabled (for easy toggling, use "hedit" -> "Handling flags" -> toggle "NOS_INST") the bug can't be reproduced
  • I can remember reproducing a similar issue when I was working on NOS functions locally. When setting the "NOS" level while no NOS upgrade was available, it would have odd effects. Apparently applying handling updates removes the NOS upgrade from the vehicle. However, oddly, it's still visible inside the vehicle
TagsNo tags attached.

Activities

qaisjp

2011-08-11 12:22

administrator   ~~0014232

My friend seems to have reproduced this, he addded some handling edits and started it in the editor, he makes a race map but when driving throug the nitros, it wouldn't add.

Cazomino05

2011-08-15 08:40

reporter   ~~0014288

Last edited: 2011-08-15 08:41

NOS_INST = NOS installed.

and you wonder why NOS is disabling... lol

as for the side effects like reversing of doing this I'll figure something out

it's because some nub is telling GTA the car doesn't have NOS when it does, same for hydraulics

Picard

2011-08-21 16:40

updater   ~~0014377

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=3036 )

Issue History

Date Modified Username Field Change