View Issue Details

IDProjectCategoryView StatusLast Update
0006341Multi Theft Auto : San AndreasClientpublic2011-08-11 11:59
ReporterNeO_D-PowerAssigned Toccw 
PrioritynormalSeverityminorReproducibilityrandom
Status resolvedResolutionfixed 
PlatformMTA:SA 1.0.5OSWindowsOS Version7
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0006341: Assertion failure in CMultiplayerSA.cpp
Description

I keep getting an assertion failure on MTA 1.0.5, randomly (rarely).
The game freezes and in the background, an error window shows up with an error message about a failed assertion.

File: CMultiplayerSA.cpp
Line: 4721
Expression: Press IGNORE ('I' Key)
Press IGNORE ('I' Key)
Press IGNORE ('I' Key)
Press IGNORE ('I' Key)

Steps To Reproduce

I don't remember.
The game was running as usual, and when a map was loaded by Race gamemode, the game froze.

Additional Information

This has happened several times before. I cannot provide any crash dumps as there aren't any.
Also, if you choose to "Ignore" the error, the game resumes as if nothing had happened.

TagsNo tags attached.

Activities

arranTuna

2011-08-09 13:32

manager   ~~0014205

I belive this is when GTA SA freezes and this is something added to let the game continue, problem is most people aren't aware they have to press I 3 times.

http://code.google.com/p/mtasa-blue/source/detail?r=2591

NeO_D-Power

2011-08-09 13:51

viewer   ~~0014207

Well, the error message cannot be seen when playing in full-screen mode so it is impossible to be aware of this "Press 'I'" trick unless you alt-tab (if minimizing is allowed) out of it.
I know some people who actually rebooted their PCs because of this...

Picard

2011-08-11 00:42

updater   ~~0014228

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2984 )

Issue History

Date Modified Username Field Change