View Issue Details

IDProjectCategoryView StatusLast Update
0006316Multi Theft Auto : San AndreasClientpublic2011-08-10 11:42
ReporterZangoAssigned Toccw 
PrioritylowSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0006316: [1.1] Certain shaders fail because of d3d9.dll
Description

During the public beta, the bloom shader didn't work correctly. It seemed removing d3d9.dll from the GTASA directory fixed it. Is it possible MTA can detect and disable d3d9.dll to prevent it from interfering? In my case I had enbseries installed.

Steps To Reproduce

Install enbseries and enable the bloom & high res map shaders.

TagsNo tags attached.

Activities

MX_Master

2011-08-05 19:07

viewer   ~~0014152

wow, wow, it's only your problem, because your GTASA must be pretty clean to work with multiplayer

ccw

2011-08-05 19:09

administrator   ~~0014154

A warning message could be a good idea

Zango

2011-08-05 19:11

viewer   ~~0014156

MX_Master: I asked "Is it possible" as it is a convenience issue indeed. It appeared many people had this issue during beta.

benox583

2011-08-06 02:21

viewer   ~~0014157

Ye I agree with this , because it will take several weeks before someone converts enb series and other graphics mods into shader used by MTA and sometimes you d'ont want to use the shaders used in the server or you want to use an effect that the server d'ont have in his resources.

The last enb serie use automatic reflective bump maps.
They are not perfect, because they are not generated by custom normal maps, but it is better than nothing.

MX_Master

2011-08-06 05:47

viewer   ~~0014158

as a solution (many people do this) you can create new folder with game files and test other mods on it, but first folder of GTASA must be pretty clean from other mods

Picard

2011-08-09 21:10

updater   ~~0014211

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2977 )

Issue History

Date Modified Username Field Change