View Issue Details

IDProjectCategoryView StatusLast Update
0006307Multi Theft Auto : San AndreasClientpublic2011-08-06 12:29
ReporterGamesnertAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version7 64-bit
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0006307: Render targets have a tendency to break with alt+tab
Description

When using alt+tab to get out of MTA for a moment and coming back, some of the server's graphics may either have turned black or be gone entirely.

The radar uses shaders to replace the background of the map to a render target. The arrows on both the radar and the big screen are textures loaded by dxCreateTexture. The arrows work just fine, but the background (render target) is gone.

The text on the left is being drawn onto a render target once, as I guess that should cost less performance than doing dxDrawText over and over and over again. But this render target disappears as well. This render target has alpha enabled, and seems to turn transparent instead of black.

The FPS monitor in the bottom-right is still visible however. That's extremely odd, because the monitor also uses a few render targets. Yet, these remain working after alt+tab. The same applies to the "Nyan" fist replacement. This uses a render target to draw 1 out of 12 nyan images. Yet, although the radar blacks out, the Nyan cat Nyans on.

Steps To Reproduce

Get in a server with plenty of different render targets. There will surely be something that'll disappear after an alt+tab.

TagsNo tags attached.

Activities

ccw

2011-08-04 18:23

administrator   ~~0014132

The render targets aren't gone, they get cleared as a consequence of the alt-tab.
I guess there needs to be some events so you can take action.
i.e. onClientMinimize and onClientRestore

Gamesnert

2011-08-04 23:48

developer   ~~0014135

Can't the render targets simply be reset to the value they had before? Isn't there some way to store the render targets or perhaps to stop DirectX from clearing the render target?

Picard

2011-08-05 01:41

updater   ~~0014142

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2945 )

Issue History

Date Modified Username Field Change