View Issue Details

IDProjectCategoryView StatusLast Update
0006292Multi Theft Auto : EditorGUIpublic2011-07-31 00:25
ReporterarranTunaAssigned ToarranTuna 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0 
Target Version2.0Fixed in Version2.0 
Summary0006292: Progress indicator for loading procedures
Description

This will lessen the effects of #4107 by allowing players to know that the map is still loading when there maps are gigantic and or PCs are slow.

DX loading bar showing percent loaded sounds good to me.

TagsNo tags attached.

Activities

ccw

2011-07-30 18:19

administrator   ~~0014059

Good idea, although why does it take so long to load and save?

arranTuna

2011-07-30 18:32

developer   ~~0014060

Last edited: 2011-07-30 18:52

I suppose thats something I can try to work out soon. 4000 vehicles takes me 18 seconds.

Edit: going to look into optimizing it first because to load all the map data takes 1 second and then something else is taking a lot longer if we're lucky there might be a large optimization to be made.

Maccer

2011-07-30 23:37

viewer   ~~0014064

Consider using coroutines when trying to save a file, and make the map write only what has been modified.

arranTuna

2011-07-31 00:23

developer   ~~0014065

Coroutines are already used for saving and loading also I tested it now and loading is the only issue as saving is a lot faster.

Picard

2011-07-31 00:24

updater   ~~0014066

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-resources/source/detail?r=759 )

Issue History

Date Modified Username Field Change