View Issue Details

IDProjectCategoryView StatusLast Update
0006240Multi Theft Auto : San AndreasClientpublic2011-07-09 08:19
ReporterGamesnertAssigned Toccw 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
PlatformLaptopOSWindowsOS Version7 (64-bit)
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0006240: Some shader examples don't work like they should
Description

For some reason, some of the shader examples (ped shell, ped morph and water) don't work like they should. Ped shell and ped morph seem to attach the result to the closest fence it can find, (odd result is odd) while the water example doesn't really seem to show a lot of texture.

I've made a few pictures to show what it looks like for me. They should look like the images on this page: (I guess at least)

Additional Information

Only tested on my laptop, since I'm kind of 1500 km away from my PC. Therefore I can't test whether it's related to my laptop.

Specs:

  • Brand: MSI
  • Type: GT663
  • CPU: Intel i5 460M
  • GPU: NVidia GTX460M / 1.5GB DDR5
  • RAM: 4GB DDR3

I've updated to the latest nightly and the latest NVidia drivers (275.33) but no dice.

No resources but the ones in mtaserver.conf by default were running. Apart from the shader resources and - occasionally - runcode.

The UV and roadshine examples seem to work perfectly. Car paint seems to work as well, although I'm not sure whether there's something wrong with that.

TagsNo tags attached.

Activities

Jockie

2011-07-07 11:30

viewer   ~~0013899

The water effect works fine for me, but the ped shaders are not working for me either.

Intel C2Q Q8300
ATI HD5770 1GB-GDDR5
4GB DDR3

Picard

2011-07-08 04:00

updater   ~~0013912

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2866 )

ccw

2011-07-08 07:51

administrator   ~~0013916

Last edited: 2011-07-08 09:38

ped ones are working now, but the water is apparently not fixed.

Please try this: http://nightly.mtasa.com/files/shaders/test/shader_water.zip

I would like a screen shot of what this looks like thank you very much.

Jockie

2011-07-08 11:48

viewer   ~~0013919

Last edited: 2011-07-08 11:49

The new one doesn't work for me anymore.

In the water appears a sort of box. (http://bit.ly/r2V2y7)
And I also see a sort of forest with a mountain when I look from above.(http://bit.ly/n2TYRU)
EDIT: @ Forest: Nvm, I see it in the images folder.

ccw

2011-07-08 15:03

administrator   ~~0013922

Jockie, it's a test to see what's going on. (It's supposed to look a box with no flashing)

Maccer

2011-07-08 20:05

viewer   ~~0013927

I see what Jockie sees in the water now, but it flashes on and off each four seconds, unless that's controlled by setTimer.

Jockie

2011-07-08 20:08

viewer   ~~0013928

There's no flashing on my screen..
The first one, shader_water worked completely fine for me tbh.

Maccer

2011-07-08 21:01

viewer   ~~0013929

Well, I have an NVidia GTX 470 1.5GB. Somewhat like Gamesnert. What's your graphics card?

diegofkda

2011-07-09 07:46

viewer   ~~0013937

Ccw's resource doesn't work for me (using an old Nvidia Geforce4 MX Integrated).

No bad arguments, nothing... it just doesn't work (the message when starting the resource outputs).

ccw

2011-07-09 08:19

administrator   ~~0013938

It probably says 'Using technique fallback', and I didn't do a fallback effect (for older cards) because I am lazy.

Issue History

Date Modified Username Field Change