View Issue Details

IDProjectCategoryView StatusLast Update
0006210Multi Theft Auto : San AndreasClientpublic2011-07-02 01:02
ReporterdiegofkdaAssigned Toccw 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionreopened 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0006210: Creating many fonts can make to objects fade in and out (When restarting a resource several times)
Description

I've created like 6 fonts:

cabec = guiCreateFont ( "cabec.ttf", 50 )
cabecmedium = guiCreateFont ( "cabec.ttf", 30 )
cabecsmall = guiCreateFont ( "cabec.ttf", 20 )

dc = guiCreateFont ( "dc.ttf", 50 )
dcmedium = guiCreateFont ( "dc.ttf", 30 )
dcsmall = guiCreateFont ( "dc.ttf", 20 )

they aren't in any function in my script, when I restart the resource 3 times, objects start to fade in and out.

Steps To Reproduce

Create a resource with client.lua and meta.xml, add just these lines:

cabec = guiCreateFont ( "cabec.ttf", 50 )
cabecmedium = guiCreateFont ( "cabec.ttf", 30 )
cabecsmall = guiCreateFont ( "cabec.ttf", 20 )

dc = guiCreateFont ( "dc.ttf", 50 )
dcmedium = guiCreateFont ( "dc.ttf", 30 )
dcsmall = guiCreateFont ( "dc.ttf", 20 )

then start the resource, and restart it 3 times.

Additional Information

I've tested this in my local server, with just 10 resources loaded and 3 players online.
I got the problem of the objects fading in and out, but not the others players (they've a modern computer, I have a 2001 computer with RAM upgraded).

TagsNo tags attached.

Relationships

related to 0006223 closed New issues Creating many fonts will eventually fill memory to bursting point 

Activities

Maccer

2011-06-28 08:42

viewer   ~~0013822

I have a 2001 computer with RAM upgraded.

Huh, so wait, what is your video card then, and what OS are you running (just asking since GTA can be ran on Windows 2000.)?

Either way on a machine that old, I'd recommend getting the latest video card drivers and getting the latest DirectX runtime files.

diegofkda

2011-06-28 23:56

viewer   ~~0013835

2001 PC with RAM upgraded, I didn't buy it so I don't know exactly about that, I just can say it has 512 RAM, NVIDIA GeForce4 MX integrated GPU 64 MB and prossesor AMD Athlon XP +2600 2.1 GHz.
My OS is Windows XP, I can run correctly 1.0.5 and before (my game runs with 15 - 25 fps).

arranTuna

2011-06-29 12:06

manager   ~~0013837

Your computer doesn't have enough memory for all those fonts and objects then. 2001, thats 10 years old so no wonder its going to be a problem.

Maccer

2011-06-29 16:00

viewer   ~~0013841

Last edited: 2011-06-29 16:04

Well he said it happens after a couple of restarts, so maybe the fonts aren't being unloaded or freed by DirectX and MTA.

Try downloading the following:

Lastest DirectX Runtime Redistributable: http://www.microsoft.com/download/en/details.aspx?id=35

Lastest NVidia Drivers For Gefore4 MX Integrated: http://www.nvidia.com/object/winxp_2k_93.71_2.html

ccw

2011-06-30 00:24

administrator   ~~0013859

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2851

diegofkda

2011-07-01 00:33

viewer   ~~0013872

Last edited: 2011-07-01 00:34

arranTuna, old computers have to be considered too, GTA:SA is an old game, so why I have to get a new computer? I've seen many lagger people, I guess 30% from the MTA players have an old computer...

By the way, I have DirectX 9 (10 and above lags for me) and I have the latest NVIDIA drivers (they're working correctly, it's just an issue the font stuff).

diegofkda

2011-07-01 22:32

viewer   ~~0013874

Last edited: 2011-07-02 00:11

False, this bug keeps happening, now loading 10 fonts (without restart the resource) can lag the objects - Engine functions are unuseable with those 10 fonts loaded.

EDIT: Well, now I'm thinking that this should be fixed in another version, as I can see, the MTA requeriments aren't the same last time (and people with modern computers don't care that), that means MTA will lost a big players quantity... I don't have lags (and see the problems I'm getting), and I know many people that have lags, so try to imagine... well I mean the people that really have lag won't be able to play 1.1...

ccw

2011-07-02 01:02

administrator   ~~0013876

Last edited: 2011-07-02 01:03

The memory leak causing this problem has been fixed. Please see #6223 for the related issue.

Issue History

Date Modified Username Field Change