View Issue Details

IDProjectCategoryView StatusLast Update
0006207Multi Theft Auto : San AndreasScriptingpublic2011-06-28 14:01
ReporterccwAssigned Toccw 
PriorityimmediateSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0006207: function name 'areInteriorSoundsEnabled' makes my tummy hurt
Description

Should it be renamed? Here are the choices:

Choice 1 As it is now
setInteriorSoundsEnabled
areInteriorSoundsEnabled

Choice 2 are -> is
setInteriorSoundsEnabled
isInteriorSoundsEnabled

Choice 3 -s
setInteriorSoundEnabled
isInteriorSoundEnabled

TagsNo tags attached.

Activities

Talidan

2011-06-27 20:03

administrator   ~~0013811

Last edited: 2011-06-27 20:04

What about getInteriorSoundsEnabled?

Though overall i'd go for Option 3

Remi-X

2011-06-27 20:06

reporter   ~~0013812

I have to agree with Talidan.
isInteriorSoundsEnabled isn't grammatically right ( is sounds? ), and isInteriorSoundEnabled isn't a plural while there are multiple sounds to be disabled.

arranTuna

2011-06-27 20:09

manager   ~~0013813

"Are interior sounds enabled?"

Sounds more correct than "Is interior sounds enabled?" or "Is interior sound enabled?"

So in my view choice 1 is best however choice 2 will work and your tummy ache will go away. Sounds rather than sound because there are different sounds in different interiors.

diegofkda

2011-06-27 21:40

viewer   ~~0013815

Last edited: 2011-06-27 21:40

setInteriorSoundEnabled
getInteriorSoundEnabled

its perfect.

ryden

2011-06-27 21:43

manager   ~~0013816

I would call it areFriesReadyToBeEaten()

Remi-X

2011-06-27 21:47

reporter   ~~0013817

far from perfect imo :P

Issue History

Date Modified Username Field Change