View Issue Details

IDProjectCategoryView StatusLast Update
0006166Multi Theft Auto : San AndreasClientpublic2011-06-19 13:16
ReporterarranTunaAssigned ToGamesnert 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0006166: [1.1 Beta] Moving doors don't move
Description

A serious bug (and probably not the only) which only effects doors added by MTA and not GTA SA doors and is going to break a lot of peoples maps. I believe the only change made which could cause something like this would be: http://code.google.com/p/mtasa-blue/source/detail?r=2312 and that was his last commit which was 5 months a go so no hope of him fixing it for 1.1

There is also this bug which was added by object sync: http://bugs.mtasa.com/view.php?id=5886 If somebody reverts r2312 and make a new nightly I can test to see if it was the cause.

I've even made a video! http://www.youtube.com/watch?v=zHEa3ZOllFg

Steps To Reproduce

Add a moving door with createObject or map file and notice it doesn't move.

TagsNo tags attached.

Activities

Maccer

2011-06-11 06:11

viewer   ~~0013629

Just curious, what's the object ID for that wooden door?

Dragon

2011-06-11 11:18

reporter   ~~0013630

might be just some overloooked value. i think there's no need to panic

Cazomino05

2011-06-18 00:40

reporter   ~~0013697

please could you post the object ID you used or retest whichever is more convenient I can't reproduce this with about 3 doors I've tried but my copy of editor isn't working at the moment so I can't find the one in the video

arranTuna

2011-06-18 10:49

manager   ~~0013700

Gen_doorINT01 1491
Gen_doorINT05 1499
Gen_doorINT04 1502
Gen_doorEXT10 1523

They won't move when you walk into them or shoot them and they're meant to.

arranTuna

2011-06-18 11:05

manager   ~~0013701

Last edited: 2011-06-19 10:14

I've uploaded a resource which you can use. It spawns you at grove street where there are 4 doors which will work fine in 1.0.5 but won't budge in 1.1

Edit: After further testing it is certain that it is the object sync because a client side door works as normal but when the object is server side it won't budge.

Picard

2011-06-19 13:16

updater   ~~0013710

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2815 )

Issue History

Date Modified Username Field Change