View Issue Details

IDProjectCategoryView StatusLast Update
0006164Multi Theft Auto : San AndreasClientpublic2011-06-09 19:52
ReporterarranTunaAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.1 
Summary0006164: [1.1 Beta] postGUI in dxDrawText may not work
Description

Recently a script which was drawing text over GUI has stopped working as the text is being drawn behind the GUI. We made some DX text in guieditor and moved it over the GUI with postGUI as true, it worked as normal which was odd.

However if you create some DX text in runcode:

crun addEventHandler("onClientRender",root,function() dxDrawText("aaaaaaaaaaaaaa", 500, 500, 100, 100, tocolor(255, 255, 0, 255), 2, "default", "left", "left", true, true, true) end)

And in guieditor create a GUI image, and move that image over the text, the text will be behind the GUI even though postGUI is true in the dxDrawText.

To reproduce you have to follow the above because it only seems to stop working in some ways and not with other scripts.

TagsNo tags attached.

Activities

ccw

2011-06-08 23:25

administrator   ~~0013615

The problem is in the way it processes incorrect arguments (after a recent change I made). The second "left" should be "top", "center" or "bottom".

I think I'm going to have to change the way it handles mismatches.

Picard

2011-06-09 19:52

updater   ~~0013623

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2777 )

Issue History

Date Modified Username Field Change