View Issue Details

IDProjectCategoryView StatusLast Update
0006161Multi Theft Auto : San AndreasClientpublic2011-07-12 22:26
ReporterdiegofkdaAssigned Toccw 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0006161: Multi Theft Auto.exe doesn't close
Description

Multi Theft Auto.exe doesn't close after closing it with Tast Manager or any program that closes the game, it will cause that the user can't open the MTA SA 1.1 again till system restart.

Additional Information

I tested just with Task Manager.

TagsNo tags attached.

Activities

arranTuna

2011-06-07 10:39

manager   ~~0013610

You are trying to end the process with administrator, right?

diegofkda

2011-06-09 02:39

viewer   ~~0013616

yep

diegofkda

2011-06-09 02:39

viewer   ~~0013617

I said Tast Manager... I mean Task Manager.

arranTuna

2011-06-09 12:30

manager   ~~0013619

I really don't think a process can prevent itself from being ended unless its a system process.

You are actually trying to end the process and not the task, right?

adamix.ru

2011-06-09 12:42

viewer   ~~0013620

Last edited: 2011-06-09 12:43

Killing task can be prevented by anti-virus software. What anti-virus you are using?

diegofkda

2011-06-09 23:53

viewer   ~~0013626

Well, I tried to stop the MTA: San Andreas from Aplications tab, when I close, the Multi Theft Auto.exe proccess doesn't close, but closes in 1.0.5.

Ca11um

2011-06-09 23:56

reporter   ~~0013627

I'd recommend using the Processes tab to stop programs executing. Applications tab tries to close them like you would by pressing the X button, where as Processes tab physically kills the process.

diegofkda

2011-06-11 23:31

viewer   ~~0013634

Well, MTA:SA doesn't close too when I close it pressing right-click (on Windows bar) and close.

Maccer

2011-06-12 08:07

viewer   ~~0013639

Confirmed. MTA closes really slowly or doesn't close at all.

MX_Master

2011-06-12 08:49

viewer   ~~0013647

Last edited: 2011-06-12 08:50

Well, MTA:SA doesn't close too when I close it pressing right-click (on Windows bar) and close.

for me it closes fast and there are no mtasa processes in process list. Using WinXP sp3, 1.1-2791

diegofkda

2011-06-13 06:16

viewer   ~~0013664

Last edited: 2011-06-13 06:19

Seems to happen with some computers, my OS is Windows XP Professional version 2002.
My PC is an old PC with 512 in RAM, 2.1 GHz AMD Athlon XP processor and NVIDIA GeForce4 MX Integrated GPU with 64 mb VRAM.

MX_Master

2011-06-13 16:00

viewer   ~~0013665

i think problem may be in other soft

Remi-X

2011-06-22 13:58

reporter   ~~0013769

I can reproduce this on my craptop, but not on my desktop. Slow performance seems to cause this, as my laptop is slow as hell, and my desktop isn't. Diego's PC is bad too.

Also, adamix has a point too. This craptop is using AVG, my desktop is using Avira. That might be a difference too.

diegofkda

2011-06-25 05:21

viewer   ~~0013788

I'm using NOD32 antivirus.
Usually, I play with MSN and the antivirus opened.

Picard

2011-06-26 06:09

updater   ~~0013800

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2838 )

diegofkda

2011-06-27 00:53

viewer   ~~0013809

It's not fixed, the MTA:SA keeps not closing at all.

diegofkda

2011-07-11 20:06

viewer   ~~0013960

Fortunately, I'm not able to reproduce this anymore on the latest Nightly :) (with the same computer).

diegofkda

2011-07-12 22:22

viewer   ~~0013970

Well this bug should be marked as fixed? No friend is able to reproduce this anymore.

ccw

2011-07-12 22:26

administrator   ~~0013971

This got fixed for the same reason crash dumps started to work again

Issue History

Date Modified Username Field Change