View Issue Details

IDProjectCategoryView StatusLast Update
0006151Source patchesMulti Theft Auto : San Andreaspublic2011-06-07 18:53
ReporterCa11umAssigned To 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0006151: Fix for issue #4643 - desync when setting vehicle's dimension
Description

This patch makes it so when a vehicle's dimension is changed, all occupants of the vehicle also have their dimension changed. Removing any desync that may occur.

TagsNo tags attached.

Activities

arranTuna

2011-06-04 10:12

manager   ~~0013581

You need to convert those tabs into spaces, its a thing MTA do http://wiki.multitheftauto.com/wiki/Coding_guidelines

There is an option in Visual Studio to automatically create 4 spaces when pressing a tab which is nice and also the {} isn't needed in that if statement because it only has 1 instruction.

Also things need to be spaced out more to "Generally follow the style of the code that already exists." for example: SetElementDimension(pOccupant,usDimension);
would be more like: SetElementDimension ( pOccupant, usDimension );

Those are just some things I know that will help the patch to get added.

Gamesnert

2011-06-04 11:15

developer   ~~0013582

And what if a player's dimension is changed, instead of the vehicle's?

Ca11um

2011-06-04 15:40

reporter   ~~0013590

Gamesnert: Tested that, it seems fine - if the player's dimension is changed, they're warped out of the vehicle.

arranTuna: Thanks for the advice, fixed: http://hosting.sanlrp.net/uploads/vehicle-dimension.zip

ccw

2011-06-07 18:53

administrator   ~~0013612

I made a couple of small changes to the patch. If you have any questions on what I did, please ask.

Issue History

Date Modified Username Field Change